Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 2 years ago

Closed 22 months ago

#10472 closed Bug Report - Crash (Fixed)

mythbackend SIGSEGV in MediaServer::~MediaServer()

Reported by: Marc Randolph <mrand@…> Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

https://bugs.launchpad.net/ubuntu/+source/mythtv/+bug/958674

#0  0x08135050 in MediaServer::~MediaServer (this=0x9a0dcf0, __in_chrg=<optimized out>) at mediaserver.cpp:285
No locals.
#1  0x081350c2 in MediaServer::~MediaServer (this=0x9a0dcf0, __in_chrg=<optimized out>) at mediaserver.cpp:287
No locals.
#2  0x0814f0a8 in cleanup () at main_helpers.cpp:242
No locals.
#3  0x08062bff in ~CleanupGuard (this=<synthetic pointer>, __in_chrg=<optimized out>) at main_helpers.h:33
No locals.
#4  main (argc=268450784, argv=0x48099e91) at main.cpp:128
        a = {<QObject> = {_vptr.QObject = 0x17bd348, static staticMetaObject = {d = {superdata = 0x0, stringdata = 0x1740ea0 "QObject", data = 0x1740f40, extradata = 0x17bbde8}}, static staticMetaObjectExtraData = {objects = 0x0, static_metacall = 0x1679390 <QObject::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}, d_ptr = {d = 0x99cc728}, static staticQtMetaObject = {d = {superdata = 0x0, stringdata = 0x1749c60 "Qt", data = 0x174d580, extradata = 0x0}}}, static staticMetaObject = {d = {superdata = 0x17bbdd8, stringdata = 0x1753720 "QCoreApplication", data = 0x17537c0, extradata = 0x17bd390}}, static staticMetaObjectExtraData = {objects = 0x0, static_metacall = 0x16c84f0 <QCoreApplication::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)>}, static self = 0xbfe557d4}
        retval = <optimized out>
        mask = {static null = {<No data fields>}, static shared_null = {ref = {_q_value = 280}, alloc = 0, size = 0, data = 0x17be4b2, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, static shared_empty = {ref = {_q_value = 116}, alloc = 0, size = 0, data = 0x17be49e, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, d = 0x99e65c0, static codecForCStrings = 0x0}
        __FUNCTION__ = "main"
        cmdline = {<MythCommandLineParser> = {_vptr.MythCommandLineParser = 0x81f5e98, m_appname = {static null = {<No data fields>}, static shared_null = {ref = {_q_value = 280}, alloc = 0, size = 0, data = 0x17be4b2, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, static shared_empty = {ref = {_q_value = 116}, alloc = 0, size = 0, data = 0x17be49e, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, d = 0x99c46f0, static codecForCStrings = 0x0}, m_optionedArgs = {{d = 0x99c4cb8, e = 0x99c4cb8}}, m_namedArgs = {{d = 0x99c4c00, e = 0x99c4c00}}, m_passthroughActive = false, m_overridesImported = true, m_verbose = false}, <No data fields>}
        daemonize = true

From the backend log, it appears there may not have been any tuners defined.

Attachments (2)

ThreadStacktrace.txt (7.5 KB) - added by Marc Randolph <mrand@…> 2 years ago.
var.log.mythtv.mythbackend.log.txt.zip (30.9 KB) - added by Marc Randolph <mrand@…> 2 years ago.

Download all attachments as: .zip

Change History (7)

Changed 2 years ago by Marc Randolph <mrand@…>

Changed 2 years ago by Marc Randolph <mrand@…>

comment:1 Changed 2 years ago by Marc Randolph <mrand@…>

Actually, someone else seems to have reproduced it without the missing tuners. backend log attached.

comment:2 Changed 2 years ago by Github

Refs #10472. Initialize pointer in ctor.

Branch: master
Changeset: a1d573c0e45ab0f69f1bce3255c19658bb3590ac

comment:3 Changed 2 years ago by beirdo

  • Type changed from Bug Report - General to Bug Report - Crash

comment:4 Changed 22 months ago by beirdo

  • Owner set to danielk
  • Status changed from new to assigned

Assigning to danielk as he was the one that referenced it in a code commit. If this is solved now, the ticket should get closed.

comment:5 Changed 22 months ago by danielk

  • Resolution set to Fixed
  • Status changed from assigned to closed

I believe this was fixed by [a1d573c0e], but I was not able to reproduce and hence verify that this fixes it. Please re-open if this remains a problem.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.