Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 2 years ago

Closed 2 years ago

#10540 closed Bug Report - General (Fixed)

Service API Dvr RemoveRecorded does not work

Reported by: cletus@… Owned by:
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When calling ServiceAPI::Dvr::RemoveRecorded? mythtv's ServiceAPI needs StartTime? in MySQL ISO format, e.g.:
curl -d 'ChanId?=34006&StartTime?=2012-03-30T17:00:00Z' 'http://192.168.1.99:6544/Dvr/RemoveRecorded'

The Service API translates it into an DELETE_RECORDING message and uses the ISO format StartTime? as parameter. However, DELETE_RECODRING needs datetime ( http://www.mythtv.org/wiki/DELETE_RECORDING_(Myth_Protocol) ) and thus DELETE_RECORDING fails:

HttpServer43 remoteutil.cpp:132 (RemoteDeleteRecording?) - Failed to delete recording 34006:2012-03-30T19:00:00

Attachments (0)

Change History (3)

comment:1 Changed 2 years ago by robertm

The above is an incorrect assessment-- all input to the Service API is returned to local time by the time it is processed in the business logic. UTC is not the issue with the API. The issue is that it calls remotedeleterecording, which is not possible as the backend would need to connect to itself to issue the command.

comment:2 Changed 2 years ago by robertm

Even once the API itself is fixed, the issue also appears to be that the reporter is providing input in localtime rather than UTC.

comment:3 Changed 2 years ago by robertm

  • Resolution set to Fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.