Opened 8 years ago

Closed 8 years ago

#10594 closed Bug Report - General (Invalid)

recording rules issues after upgrade to 0.25

Reported by: willem@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.25-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Just upgraded to 0.25 (on Arch Linux using the latest package 0.25-1).

Now my frontend does not show the Recording Rules. Also no Upcoming Recordings.

In the System Status, it shows 79 standard rules and 12 search rules are defined. But 0 matching showings...

When trying to schedule a random recording, it does not show up in the Upcoming Recordings.

When I try to change one of my search rules I get the following in the console:

REPLACE INTO customexample (rulename,fromclause,whereclause,search) VALUES(?,?,?,?);
Bindings were:
:FROMC=NULL, :RULE="de wereld draait door", :SEARCH=true,
:WHEREC="program.title LIKE 'de wereld draait door%' AND WEEKDAY(program.starttime) < 5 AND HOUR(program.starttime) >= 19 
AND HOUR(program.starttime) < 23 "
Driver error was [2/1048]:
QMYSQL3: Unable to execute statement
Database error was:
Column 'fromclause' cannot be null

Change History (2)

comment:1 Changed 8 years ago by willem@…

Ha! Seems to have found the issue. After the upgrade the fields "local backend" and "master backend" where wrong. The first contained '127.0.0.0' the latter the name of the box. Either the previous version (0.24) worked ok with these settings or they where changed by the upgrade process. Anyway -- solved for me.

comment:2 Changed 8 years ago by Raymond Wagner

Milestone: 0.25.1unknown
Priority: criticalminor
Resolution: Invalid
Severity: highmedium
Status: newclosed
Version: Unspecified0.25-fixes
Note: See TracTickets for help on using tickets.