Opened 7 years ago

Closed 5 years ago

#10597 closed Bug Report - General (Fixed)

Quitting LiveTV to return to main menu crash

Reported by: JYA Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When using Qt painter with XVideo

leaving TV Playback always crash on my machine (using ATI Radeon open source drivers)

Using Arclight theme

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff63ed68e in MythQtPainter::DeletePixmaps (this=0xbe24a0)
    at mythpainter_qt.cpp:71
71	        QPixmap *pm = m_imageDeleteList.front();
(gdb) bt
#0  0x00007ffff63ed68e in MythQtPainter::DeletePixmaps (this=0xbe24a0)
    at mythpainter_qt.cpp:71
#1  0x00007ffff63ed86d in MythQtPainter::Begin (this=0xbe24a0, parent=0xbe2e80)
    at mythpainter_qt.cpp:91
#2  0x00007ffff63c59ad in MythMainWindow::draw (this=0xba03c0)
    at mythmainwindow.cpp:777
#3  0x00007ffff63c580c in MythMainWindow::drawScreen (this=0xba03c0)
    at mythmainwindow.cpp:767
#4  0x00007ffff63c4170 in MythPainterWindowQt::paintEvent (this=0xbe2e70, 
    pe=0x7fffffffc590) at mythmainwindow.cpp:413
#5  0x00007ffff46950f6 in QWidget::event(QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#6  0x00007ffff4644894 in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#7  0x00007ffff4649713 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#8  0x00007ffff3dd5e9c in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007ffff4690d96 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#10 0x00007ffff4691a0f in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#11 0x00007ffff4690acc in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#12 0x00007ffff4861b68 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#13 0x00007ffff4687ac0 in QWidgetPrivate::syncBackingStore() ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#14 0x00007ffff469560c in QWidget::event(QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#15 0x00007ffff63c6a87 in MythMainWindow::event (this=0xba03c0, e=0x3ccf4d0)
    at mythmainwindow.cpp:926
#16 0x00007ffff4644894 in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#17 0x00007ffff4649713 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#18 0x00007ffff3dd5e9c in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#19 0x00007ffff3dd9c6a in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#20 0x00007ffff3e04f93 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#21 0x00007fffeab2ac9a in g_main_context_dispatch ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fffeab2b060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fffeab2b124 in g_main_context_iteration ()
   from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007ffff3e053bf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#25 0x00007ffff46ecd6e in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#26 0x00007ffff3dd4c82 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#27 0x00007ffff3dd4ed7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#28 0x00007ffff3dd9f67 in QCoreApplication::exec() ()
   from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#29 0x0000000000461d8f in main (argc=1, argv=0x7fffffffe218) at main.cpp:1762

Change History (3)

comment:1 Changed 6 years ago by Karl Egly

another datapoint, Mythbuntu 12.04LTS + latest master + the open source Radeon driver + Terra or Mythcenter-wide still cause this segfault when leaving recording playback.

comment:2 Changed 5 years ago by JYA

now get a blank screen (but no crash)

comment:3 Changed 5 years ago by JYA

Resolution: Fixed
Status: newclosed

can't reproduce with latest mesa OSS drivers found in 14.04

Note: See TracTickets for help on using tickets.