Opened 8 years ago

Closed 8 years ago

#10654 closed Bug Report - General (Invalid)

mythfrontend telnet interface does not listen on correct address

Reported by: jrsantos@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.25
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

The telnet interface of mythfrontend only tries to listen on the loopback addresses and the backend server addresses. This is inappropriate when the frontend runs on a different host than the backend.

Change History (3)

comment:1 Changed 8 years ago by Raymond Wagner

Resolution: Invalid
Status: newclosed

Incorrect. The frontend control socket (it's not telnet) listens on localhost, and whatever IP address you have configured as the server address for that host. If none are defined, it will listen to all available private addresses. If it is complaining that the selected address does not exist, then you have misconfigured those addresses in mythtv-setup.

comment:2 Changed 8 years ago by jrsantos@…

Resolution: Invalid
Status: closednew

That used to be the case, but commit f5aa5e83 changes it to use the addresses found in ServerPool::SelectDefaultListen?(). If the BackendServerIP setting is non-null, then it uses this value for the listen address.

If I run the frontend and backend on the same host, with the backend server address configured to 127.0.0.1 via mythtv-setup, then the telnet interface only binds to the loopback addresses. Changing BackendServerIP to the host's LAN address causes the telnet interface to bind to the LAN address.

comment:3 Changed 8 years ago by Raymond Wagner

Resolution: Invalid
Status: newclosed
Ticket locked: set

However you want to word it, that is the intended behavior.

Note: See TracTickets for help on using tickets.