Opened 7 years ago

Closed 5 years ago

Last modified 8 months ago

#10707 closed Bug Report - General (Works for me)

mythweb displays broken links to preview images

Reported by: brian@… Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: 0.25-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When I load the "Recorded Programs" page in mythweb it will typically show a few broken links for a few of the most recent preview images. Simply refreshing fills the broken links in with preview images, quite quickly -- clearly from disk.

Seems there is some kind of race or timeout issue happening.

Change History (14)

comment:1 Changed 7 years ago by Rob Smith

Status: newinfoneeded_new

Can you add the apache logs when this happens?

comment:2 Changed 7 years ago by brian@…

OK. It just happened again. Two episodes which are showing a broken link icon instead of a thumbnail. Looking at what was fetched for one of them:

<a class="x-pixmap" href="http://pvr/mythweb/tv/detail/3093/1365469200" title="Recording Details"
            ><img src="http://pvr/mythweb/tv/get_pixmap/pvr/3093/1365469200/100/75/-1/3093_20130409010000.mpg.100x75x-1.png" width="100" height="75"></a>

and then grepping the access_log for 1365469200:

# grep "1365469200" /var/log/apache2/access.log
1.5.2.1 - - [09/Apr/2013:18:11:54 -0400] "GET /mythweb/tv/get_pixmap/pvr/3093/1365469200/100/75/-1/3093_20130409010000.mpg.100x75x-1.png HTTP/1.1" 200 385 "http://pvr/mythweb/tv/recorded" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.22 (KHTML, like Gecko) Ubuntu Chromium/25.0.1364.160 Chrome/25.0.1364.160 Safari/537.22"
1.5.2.1 - - [09/Apr/2013:18:11:59 -0400] "GET /mythweb/tv/get_pixmap/pvr/3129/1365469200/100/75/-1/3129_20130409010000.mpg.100x75x-1.png HTTP/1.1" 200 384 "http://pvr/mythweb/tv/recorded" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.22 (KHTML, like Gecko) Ubuntu Chromium/25.0.1364.160 Chrome/25.0.1364.160 Safari/537.22"

So the log doesn't show a 404.

And if I refresh the page, the thumbnail will actually draw the second time around.

comment:3 Changed 6 years ago by paulh

Status: infoneeded_newnew

comment:4 Changed 5 years ago by Rob Smith

Resolution: Works for me
Status: newclosed

I can't reproduce this.

comment:5 in reply to:  4 Changed 5 years ago by brian@…

Replying to kormoc:

I can't reproduce this.

But I can with 100% reliability so it seems a bit short-sighted to close the ticket just because one person cannot reproduce the problem. Perhaps these are related since they occur when trying to load the Recorded page:

Aug 31 07:48:46 pvr mythbackend: mythbackend[2170]: E HttpServer126 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:48:47 pvr mythbackend: mythbackend[2170]: E HttpServer125 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:48:47 pvr mythbackend: mythbackend[2170]: E HttpServer127 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:48:47 pvr mythbackend: mythbackend[2170]: E HttpServer142 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:48:51 pvr mythbackend: mythbackend[2170]: E HttpServer69 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:16 pvr mythbackend: mythbackend[2170]: E HttpServer116 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:19 pvr mythbackend: mythbackend[2170]: E HttpServer120 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:20 pvr mythbackend: mythbackend[2170]: E HttpServer121 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:20 pvr mythbackend: mythbackend[2170]: E HttpServer123 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:20 pvr mythbackend: mythbackend[2170]: E HttpServer125 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:26 pvr mythbackend: mythbackend[2170]: E HttpServer69 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:49 pvr mythbackend: mythbackend[2170]: E HttpServer116 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:52 pvr mythbackend: mythbackend[2170]: E HttpServer118 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:53 pvr mythbackend: mythbackend[2170]: E HttpServer121 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:53 pvr mythbackend: mythbackend[2170]: E HttpServer123 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:53 pvr mythbackend: mythbackend[2170]: E HttpServer126 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:49:59 pvr mythbackend: mythbackend[2170]: E HttpServer69 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:50:26 pvr mythbackend: mythbackend[2170]: E HttpServer121 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:50:50 pvr mythbackend: mythbackend[2170]: E HttpServer116 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:50:55 pvr mythbackend: mythbackend[2170]: E HttpServer123 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:51:30 pvr mythbackend: mythbackend[2170]: E HttpServer121 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (141)
Aug 31 07:52:13 pvr mythbackend: mythbackend[2170]: E HttpServer64 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (128)
Aug 31 07:52:20 pvr mythbackend: mythbackend[2170]: E HttpServer117 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (128)
Aug 31 07:52:28 pvr mythbackend: mythbackend[2170]: E HttpServer64 previewgenerator.cpp:265 (Run) Preview: Encountered problems running '/usr/bin/mythpreviewgen' (128)

But as I have mentioned, they are transient/load related since they only occur on the first attempt to load the Recorded page and the broken links will go away if I refresh the page which of course instructs the server to regenerate the previews.

comment:6 Changed 3 years ago by jan@…

I see this too now. The result sent back from Content/GetPreviewImage? is actually:

<?xml version="1.0" encoding="UTF-8"?><></>

instead of the image data. Reloading fixes this.

comment:7 Changed 3 years ago by jan@…

Oh, and I'm running the latest 0.28-fixes.

comment:8 Changed 3 years ago by nige@…

I was experiencing this issue and found that my Apache log was littered with "AH01797: client denied by server configuration". By migrating the Apache access control directives (https://httpd.apache.org/docs/2.4/upgrading.html) to those preferred by 2.4 the errors in the log disappeared, and my images started to show on first page load.

comment:9 Changed 3 years ago by nige@…

Scrub that. I spoke too soon. It's back again :( I'm also using 0.28-fixes.

comment:10 Changed 2 years ago by clueo8@…

I'm on v0.28.1-38-geef6a48 and also seeing this issue. Thumbnails are broken when you initially go to recordings in mythweb... I manually go to the image url in a browser and refresh 2-3 times and then the thumbnail finally paints... Not seeing anything in the logs, apache is sending 200s everytime...

comment:11 Changed 2 years ago by thomas@…

Just updated from 0.27.x to 0.28.1 and I have the same problem. I have broken thumbnails in MythWeb for new recordings. Sometimes, it is enough to reload the recordings page a few times, but sometimes it is not. Then I open the thumbnail in a new browser tab. It shows a black page. Then I reload that page 1-2 times and the image shows up. Then back on the recordings page, it also shows up after another reload of the page. I see from the file dates, that *all* missing thumbnails had been created after the first loading of the recordings page, but MythWeb would not show them until that trick with opening it in a new tab with each of them.

comment:12 Changed 2 years ago by Peter Bennett

I suggest look at the apache log file and see if an error is reported there. Perhaps some setting is being exceeded.

comment:13 Changed 2 years ago by thomas@…

There is no error in the Apache log. I can see, that the browser does not even try to load the broken images after I reload the page with F5. It seems that Chrome decides for itself, that it does not want to try to load the broken images again. Force reload (CTRL + click on reload button) fixes the issue.

comment:14 Changed 8 months ago by rcrdnalor

I do get the broken thumbnails as well. This is a regression since fixes/0.28

See #13404 for details on how to reproduce it. This bug report contains also a proposed patch.

Note: See TracTickets for help on using tickets.