Opened 7 years ago

Closed 6 years ago

#10743 closed Bug Report - General (Invalid)

After upgrade to 0.25 from 0.24.xx channel change is awfully slow

Reported by: xyz@… Owned by:
Priority: trivial Milestone: unknown
Component: MythTV - General Version: 0.25-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

Previously, i changed channels in round about 3 seconds. Now it takes up to 40 seconds!

Attachments (2)

backend.log (34.5 KB) - added by Raymond Wagner 7 years ago.
frontend.log (25.2 KB) - added by Raymond Wagner 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by danielk

Priority: majortrivial
Severity: mediumlow
Status: newinfoneeded_new

Please attach "mythbackend -v record,channel" and "mythfrontend -v playback,channel" logs showing the slow channel change.

I've reset the priority and severity. These are meant to be set after triage.

Changed 7 years ago by Raymond Wagner

Attachment: backend.log added

Changed 7 years ago by Raymond Wagner

Attachment: frontend.log added

comment:2 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Status: infoneeded_newnew

comment:3 Changed 6 years ago by Karl Egly

I see name lookup failures in both frontend and backend log, from the frontend log:

2012-05-24 22:18:45.612649 E  No address defined for host: localhost
2012-05-24 22:18:45.613117 E  Connection to master server timed out.
                              Either the server is down or the master server settings
                              in mythtv-settings does not contain the proper IP address

please try changing that to 127.0.0.1 instead. According to the howto its also important that the value matches (aka all fields either localhost or 127.0.0.1, no mixing) in all places.

In the backend log I also see:

2012-05-24 22:18:43.238209 E  PSIP packet failed CRC check. pid(0x1000) type(0x82)
2012-05-24 22:18:43.238233 E  PSIP packet failed CRC check. pid(0x1002) type(0x83)

which appear to be a subset of #10495 (CRC error on ECM/EMM tables which don't have CRC at all)

comment:4 Changed 6 years ago by xyz@…

Oh, sorry, thank you! Already forgot this task.

Yes, finally, after longer try-outs i found some mismatch in the configured IP's. If i remember correctly, i mixed localhost and the host's public ip.

Best regards Florian

comment:5 Changed 6 years ago by Karl Egly

Resolution: Invalid
Status: newclosed

thanks for reporting back, I'm closing it as "not a bug"

Note: See TracTickets for help on using tickets.