Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 2 years ago

Closed 21 months ago

#10768 closed Bug Report - General (fixed)

Unable to record with mpeg-4 software encoding

Reported by: ggervasio@… Owned by: danielk
Priority: minor Milestone: 0.26
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

With recent master (v0.26-pre-409-gc51c98a), I am unable to record with mpeg-4 software encoding. There are two issues:

  1. The recording profile codec settings are not loaded correctly, so the recorder defaults to RTjpeg:
2012-05-28 08:55:01.135476 I  TVRec(17): Starting Recorder
2012-05-28 08:55:01.167617 I  Using profile 'Default' to record
2012-05-28 08:55:01.167632 I  TVRec(17): rec->GetPathname(): '/home/mythtv/store
.w2/1007_20120528085500.nuv'
2012-05-28 08:55:01.168862 I  DTVRec(17): ResetForNewFile(void)
2012-05-28 08:55:01.218171 E  NVR(/dev/video0): Unknown video codec.  Please go into the TV Settings, Recording Profiles and setup the four 'Software Encoders' profiles.  Assuming RTjpeg for now.
2012-05-28 08:55:01.218210 E  NVR(/dev/video0): Unknown audio codec

Another symptom of the problem is that the video/audio codec settings in mythtv-setup "Recording Profiles" do not reflect what's in the database and changes do not appear to stick.

This problem appears to be due to settings changes in 84974039959d2372844a39a820ca4c7530df5a58. I'm not sure why, but the attached hack seems to make it work.

  1. With the codec settings loaded correctly, the recordings do not contain any video. This appears due to changes to use new ffmpeg API. The second patch makes it work.

Attachments (2)

settings_profile-v0.26-pre-409-gc51c98a.patch (1.1 KB) - added by ggervasio@… 2 years ago.
hack for recording profile settings
av_encode-v0.26-pre-409-gc51c98a.patch (682 bytes) - added by ggervasio@… 2 years ago.
fix mpeg-4 video encode

Download all attachments as: .zip

Change History (5)

Changed 2 years ago by ggervasio@…

hack for recording profile settings

Changed 2 years ago by ggervasio@…

fix mpeg-4 video encode

comment:1 Changed 2 years ago by danielk

  • Milestone changed from unknown to 0.26
  • Owner set to danielk
  • Status changed from new to assigned

comment:2 Changed 2 years ago by Daniel Kristjansson <danielk@…>

In 3a086e3dbd18c9147202a299fc1c080c282f37e6/mythtv:

Refs #10768. Allow ComboBoxSetting::SetDBValue() to set a value for a not yet loaded selection list.

comment:3 Changed 21 months ago by Gregorio Gervasio, Jr <ggervasio@…>

  • Resolution set to fixed
  • Status changed from assigned to closed

In fe6e4df0fdaf976ee235c912f7a167a1eb8e80d0/mythtv:

Fixed libavcodec video encoding.

Fixes #10768

Signed-off-by: Gavin Hurlbut <ghurlbut@…>

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.