Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#10792 closed Developer Task (Duplicate)

Please bump Gentoo ebuilds to 0.25

Reported by: Alec M <alecm@…> Owned by: Raymond Wagner
Priority: minor Milestone: 0.27
Component: Packaging Version: 0.25
Severity: medium Keywords:
Cc: Ticket locked: no

Description

MythTV 0.25 has been released almost 2 months ago, but there are still no ebuilds for it (except, oddly, mythweb which has versions for both 0.25 and 0.26)

Someone even opened a pull request here: https://github.com/MythTV/packaging/pull/28

Change History (12)

comment:1 Changed 8 years ago by Raymond Wagner

Milestone: unknown0.26
Owner: set to Raymond Wagner
Status: newassigned
Type: Bug Report - GeneralDeveloper Task

I haven't bumped the ebuilds, as it hasn't been necessary. There haven't been any changes that needed to be made besides those four lines at the top. The MythWeb ebuild was updated because it was broken. For all others, you are recommended to use the packaged script to update the ebuilds for whatever version of MythTV you want to run.

For 0.25:

scripts/build-ebuild.py --version=0.25 --type=p

For 0.26:

scripts/build-ebuild.py --version=0.26 --type=pre

If there are updates or changes to make besides those four variables at the top, I will accept those and update the ebuilds. Otherwise, I am working on a replacement for the above script, which I intend to tie into an autobuild system similar to how MythBuntu? does their stuff, which automatically bumps as needed if the ebuild compiles and installs successfully.

comment:2 Changed 8 years ago by Alec M <alecm@…>

OK, thanks for the info!

I suspected that the last -rc was not much different from 0.25, but I found it weird that mythweb was bumped to 0.25/0.26 and the 0.24 was removed (even though the rest of 0.24 was not, resulting in portage wanting to downgrade my mythweb to the "official" Gentoo version), so I guessed that maybe the there was an update but it just wasn't pushed.

comment:3 Changed 7 years ago by Achim Hofmann <info@…>

Could you please take it in consideration to include this information into the README file within the Gentoo folder?

Thank you very much!

comment:4 Changed 7 years ago by userblues@…

I'm getting this (and I've seen at least one other user having same trouble):

scripts/mythtv-buildebuild.py --version=0.25 --type=p
Traceback (most recent call last):
  File "scripts/mythtv-buildebuild.py", line 312, in <module>
    Ebuild(package).update()
  File "scripts/mythtv-buildebuild.py", line 79, in update
    self.get_cur()
  File "scripts/mythtv-buildebuild.py", line 190, in get_cur
    commits = json.load(urllib.urlopen("http://github.com/api/v2/json/commits/list/mythtv/MythTV/"+self.branch))
  File "/usr/lib64/python2.7/json/__init__.py", line 278, in load
    **kw)
  File "/usr/lib64/python2.7/json/__init__.py", line 326, in loads
    return _default_decoder.decode(s)
  File "/usr/lib64/python2.7/json/decoder.py", line 366, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib64/python2.7/json/decoder.py", line 384, in raw_decode
    raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded
Last edited 7 years ago by Raymond Wagner (previous) (diff)

comment:5 Changed 7 years ago by Raymond Wagner

Github removed support for their v2 API on the 12th, which is what that script used. I've been out of town the past week, and hadn't had time to work on the replacement. I will try to have that ready by this weekend.

comment:6 Changed 7 years ago by Achim Hofmann <info@…>

@wagnerrp: Three months have passed by and unfortunately there haven't been any changes to the Gentoo directory within the mythtv-packaging repository. Can you give us an update about this, please?

comment:7 Changed 7 years ago by Alec <alecm@…>

Just as an FYI, the latest (stable) MythTV is now in portage, and updated regularly.

comment:8 Changed 7 years ago by foontala@…

Thanks to those that made this possible! That package generation stuff was pretty cool. Did that get leveraged into something that will be used regularly?

comment:9 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Milestone: 0.260.26.1

comment:10 Changed 6 years ago by paulh

Milestone: 0.26.10.28

comment:11 Changed 6 years ago by paulh

Resolution: Duplicate
Status: assignedclosed

Duplicate of #10881 which has a patch

comment:12 Changed 6 years ago by Stuart Auchterlonie

Milestone: 0.280.27
Note: See TracTickets for help on using tickets.