Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 21 months ago

Closed 21 months ago

#10923 closed Bug Report - General (fixed)

MythTranscode HLS never includes the last mpeg-ts segment

Reported by: jyavenard Owned by: Chris Pinkham <cpinkham@…>
Priority: minor Milestone: 0.26
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

As soon as an error is encountered. Mythtranscode abort, and the data already decoded is lost.

So you always miss the last few seconds of a transcode, up to around 10s

Attachments (0)

Change History (2)

comment:1 Changed 21 months ago by jyavenard

Looking at httplivestream.cpp the issue is that as hlsstreamid is == -1, the last segment isn't written on the playlist.

HTTPLiveStream::WritePlaylist?(bool audioOnly, bool writeEndTag) is always called with writeEndTag set to false, so the last segment is always ignored

comment:2 Changed 21 months ago by Chris Pinkham <cpinkham@…>

  • Owner set to Chris Pinkham <cpinkham@…>
  • Resolution set to fixed
  • Status changed from new to closed

In aef3087b25b8b317123d3ad058fc4fdb8a80540a/mythtv:

HLS Fix and mythtranscode optimization.

  • Eliminate AudioReencodeBuffer::GetCount?() usage and method itself.
  • Call HTTPLiveStream::InitForWrite?() when we create a live stream

using the command line invocation of mythtranscode.

Fixes #10923.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.