Opened 7 years ago

Closed 6 years ago

#10951 closed Bug Report - Hang/Deadlock (Duplicate)

another backend deadlock

Reported by: brian@… Owned by:
Priority: minor Milestone: 0.25.3
Component: MythTV - General Version: 0.25-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Not sure if this one is the same as #10939 or not and figure it's easier to close duplicate tickets than it is to unmuddy a ticket with non-related material. So here is another backend deadlock.

Version is still the same as in #10939. With any luck I will find time to do updates tomorrow.

Attachments (1)

ThreadStacktrace.txt (120.4 KB) - added by brian@… 7 years ago.
stack trace of deadlocked threads

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by brian@…

Attachment: ThreadStacktrace.txt added

stack trace of deadlocked threads

comment:1 Changed 6 years ago by Karl Egly

Status: newinfoneeded_new

I see StreamHandler::AddListener? and StreamHandler::RemoveListener? in you backtrace and I am wondering if this is still an issue, now that the fix from #10870 made it into 0.25/fixes?

comment:2 Changed 6 years ago by brian@…

I have been on 0.26/fixes for quite a while now so I don't know what the state of 0.25/fixes and this bug are any more.

comment:3 Changed 6 years ago by Karl Egly

Milestone: unknown0.25.3
Resolution: Duplicate
Status: infoneeded_newclosed

thanks for reporting back. I'm closing this as duplicate of #10870 which occurred around the same time and fits well to the backtrace.

Note: See TracTickets for help on using tickets.