Opened 7 years ago

Closed 3 years ago

Last modified 18 months ago

#10994 closed Bug Report - General (fixed)

Newly added Firewire channels fail to tune

Reported by: Peter Bennett <pgbennett@…> Owned by: Peter Bennett
Priority: minor Milestone: unknown
Component: MythTV - Channel Scanner Version: 0.25-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When new firewire channels are added by mythfilldatabase, tuning those channels fails. The Signal monitor fails to start. In LiveTV you just see a blank screen. The following messages occur in the log:

Aug  7 18:56:22 panther-ux mythbackend[11219]: E TVRecEvent tv_rec.cpp:1907 (SetupDTVSignalMonitor) TVRec(5): No valid DTV info, ATSC maj(0) min(0), MPEG pn(-1)
Aug  7 18:56:22 panther-ux mythbackend[11219]: E TVRecEvent tv_rec.cpp:1961 (SetupSignalMonitor) TVRec(5): Failed to setup digital signal monitoring
Aug  7 18:56:22 panther-ux mythbackend[11219]: E TVRecEvent tv_rec.cpp:3696 (TuningFrequency) TVRec(5): Failed to setup signal monitor

The cause is the values that have been set in the channel table on the new channels: mplexid is null, serviceid is null and atsc_major_chan = 0. The following SQL statement repairs the table so that the channels work:

update channel
set mplexid = 32767, serviceid = 0, atsc_major_chan = channum
where sourceid = 2
and (mplexid is null or serviceid is null or atsc_major_chan = 0);

The process that populates the channel table for new Firewire channels should set the correct values.

Change History (8)

comment:1 Changed 7 years ago by Peter Bennett <pgbennett@…>

I found that this also happens with channels added via the backend setup, so it is not specifically a mythfilldatabase problem. Please re-assign it to the appropriate component.

The version I am using is 2:0.25.2+fixes.20120801.46cab93-0ubuntu0mythbuntu4

Peter

comment:2 Changed 7 years ago by stuartm

Component: MythTV - MythfilldatabaseMythTV - Channel Scanner
Owner: changed from stuartm to danielk
Status: newassigned

comment:3 Changed 4 years ago by Stuart Auchterlonie

Owner: danielk deleted
Status: assignednew

comment:4 Changed 4 years ago by Gero3977@…

I appear to have this same issue on the latest stable MythTV

raansu-powerbook@PowerBookG4-Debian:~$ mythtv-setup --version
Please attach all output as a file in bug reports.
MythTV Version : ad97d24
MythTV Branch : fixes/0.27
Network Protocol : 77
Library API : 0.27.20141016-1
QT Version : 4.8.6
Options compiled in:
 linux profile use_hidesyms using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_ivtv using_joystick_menu using_libcec using_libcrypto using_libdns_sd using_libfftw3 using_libxml2 using_lirc using_mheg using_opengl using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_taglib using_v4l2 using_x11 using_xrandr using_xv using_profiletype using_mythlogserver using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_ffmpeg_threads using_mheg using_libass using_libxml2
raansu-powerbook@PowerBookG4-Debian:~$ 

comment:5 Changed 4 years ago by Gero3977@…

I can confirm the above workaround works, still no workarounds should be needed.

comment:6 Changed 3 years ago by Peter Bennett

Owner: set to Peter Bennett
Status: newassigned

comment:7 Changed 3 years ago by Peter Bennett <pbennett@…>

Resolution: fixed
Status: assignedclosed

In 65f99284fc68da0446dbdf711b6ee9bee6fd4ddf/mythtv:

Fix Channel editor missing setting

Add the Freqid setting to the common settings of channel editor
because this is required for Firewire, Ceton, HD Homerun Prime,
and maybe others.

Fixes #10994

comment:8 Changed 18 months ago by Peter Bennett

Owner: changed from Peter Bennett to Peter Bennett
Note: See TracTickets for help on using tickets.