Opened 7 years ago

Closed 6 years ago

Last modified 5 years ago

#10997 closed Patch - Bug Fix (fixed)

Don't send Diseqc if tuning to the same transponder

Reported by: warpme@… Owned by: Karl Egly
Priority: minor Milestone: 0.28
Component: MythTV - DVB Version: Master Head
Severity: medium Keywords: Unicable DVB-S
Cc: Ticket locked: no

Description

Some DVB demodulators (i.e. Montage m88ds3103) can loose LOCK when DVB app is sending Diseqc commands and consecutive tune call with re_tune=0. Issue is manifesting in MythTV when user is asking for DVB-S/S2 channel on already tuned multiplex. In such case MythTV can't get/keep lock on some multiplexes. Looking on dvbchannel.cpp:733 it seems current code can skip fe tuning if requested mplex is the same, but Diseqc commands are still sent. Attached patch turns-off sending Diseqc commands when tune is to already tuned mplex (I believe this should be by design). This patch might be especially relevant to Unicable systems as in Unicable Diseqc commands are directly impacting demodulator PLL sync state (they are controlling UB LO on Unicable LNB).

Attachments (1)

0028-mythtv-0.25-dont_send_diseq_if_tuning_to_the_same_transponder.patch (4.5 KB) - added by warpme@… 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by warpme@…

comment:1 Changed 6 years ago by Karl Egly

Owner: changed from danielk to Karl Egly
Status: newaccepted

comment:2 Changed 6 years ago by Karl Egly

note to self, apply after #9726 due to:

// retrieve scr intermediate frequency 
DiSEqCDevSCR *scr = diseqc_tree->FindSCR(diseqc_settings); 
if (lnb && scr) 
{ 
    intermediate_freq = scr->GetIntermediateFrequency(intermediate_freq); 
} 

comment:3 Changed 6 years ago by Karl Dietz <dekarl@…>

Resolution: fixed
Status: acceptedclosed

In 111a7559fec5f81d7561f46cc10800f47d331b7b/mythtv:

Add support for Unicable / Satellite Channel Router / DIN EN 50494

Our loyal user base has kept this feature patch alive since fixes/0.24
and its been reported as being (rock) solid by multiple users which
also performed regression tests against plain-old-DVB-S setups.

Patch by Matthias Benesch
With additions by Shinck and warpme
updated by k_straussberger

Fixes #9726
Fixes #10997

comment:4 Changed 5 years ago by paulh

Milestone: unknown0.28
Note: See TracTickets for help on using tickets.