Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#11 closed defect (invalid)

Automatic audio track selection fails for some DVDs.

Reported by: jdonavan Owned by: jdonavan
Priority: minor Milestone: 0.19
Component: mythtv Version:
Severity: medium Keywords: DVD, audio
Cc: Ticket locked: no

Description

Some DVDs are getting the directors commentary instead of the proper audio track. Mainly listing this here so I don't forget to look into it and so others are aware of it.

Change History (5)

comment:1 Changed 14 years ago by anonymous

This may be the same underlying cause as getting the wrong AC3 audio track. I played a ripped VOB file in 6-channel audio and got a foreign language track (not what was selected when ripping the DVD). Playing the same VOB in 2-channel stereo yielded the director's commentary instead.

comment:2 Changed 14 years ago by anonymous

I had the same issue, by updating the specific files player options ( -aid ) I was able to fix this. Seemingly if the DVD does not dictate the default audio then the player picks the first one..

So setting -aid 128 usually fixes this issue. ie mplayer -fs -quiet -zoom -aid 128 -vo xv %s

Let me know,

Sean.

comment:3 Changed 13 years ago by anonymous

That only works if the DVD's primary audio track is also the one you intended to rip from the DVD. In other words, "-aid 128" will play the English audio track on most US-released DVDs, no matter what audio track you told MythDVD to rip.

comment:4 Changed 13 years ago by Isaac Richards

Resolution: invalid
Status: newclosed

This code's been rewritten long ago, so I doubt that this bug still applies.

comment:5 Changed 13 years ago by anonymous

Confirmed. This works properly in a recent SVN snapshot.

Note: See TracTickets for help on using tickets.