Opened 7 years ago

Last modified 7 years ago

#11004 assigned Bug Report - General

Master backend tries to record to non-existent directory

Reported by: bob@… Owned by: sphery
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: 0.25.1
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Raymond Wagner)

I've had a persistent issue for about a year where the master backend will try to record to a directory listed in the storage group that isn't present on that system. The only way I've been able to get the system to work is to mount the directory using NFS, however I would prefer to have it work without doing that.

I have the storage group defined on the master backend with the following:

/var/mythtv/tv/recordings/
/var/mythtv/tv2/recordings/
/var/mythtv/tv3/recordings/
/var/tv/recordings/
/var/tv2/recordings/

The first three directories are on the master backend and the last two are on the slave backend. Nothing is defined on the slave backend. My understanding is that the master backend will realize that the last two directories do not exist on that system and not use them, however, on my system, it repeatedly tries to anyway.

I have tried removing all storage group information and re-entering it with no difference.

I posted my issue on the mythtv-users mailing list and Michael Dean asked me to provide some details which I have included below.

master backend:

bob@mythbox:~$ ls -ld /var/{,mythtv/}tv*/recordings
ls: cannot access /var/tv*/recordings: No such file or directory
drwxrwxrwx 2 bob bob  24576 2012-07-19 22:33 /var/mythtv/tv2/recordings
drwxrwxrwx 2 bob bob 126976 2012-07-24 11:43 /var/mythtv/tv3/recordings
drwxrwxrwx 2 bob bob 135168 2012-07-24 12:39 /var/mythtv/tv/recordings

bob@mythbox:~$ df -k /var/{,mythtv/}tv*/recordings
df: `/var/tv*/recordings': No such file or directory
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda2            709363588 692880936  16482652  98% /var/mythtv
/dev/sdb1            1953446464 1896418576  57027888  98% /var/mythtv/tv3
/dev/sdc1            1952558140 1895880720  56677420  98% /var/mythtv/tv

slave backend:

bob@mail:~$ ls -ld /var/{,mythtv/}tv*/recordings
ls: cannot access /var/mythtv/tv*/recordings: No such file or directory
drwxrwxrwx 2 bob bob 49152 2012-07-24 12:39 /var/tv2/recordings
drwxrwxrwx 2 bob bob 20480 2012-07-16 18:14 /var/tv/recordings

bob@mail:~$ df -k /var/{,mythtv/}tv*/recordings
df: `/var/mythtv/tv*/recordings': No such file or directory
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sdb1            976694464 919833692  56860772  95% /var/tv2
/dev/sda2            200184560 183212220  16972340  92% /var/tv

Here is the storage group table:

 +----+-------------+----------+----------------------------------+
| id | groupname   | hostname | dirname                          |
+----+-------------+----------+----------------------------------+
|  9 | Default     | mythbox  | /var/mythtv/tv/recordings/       |
| 12 | Default     | mythbox  | /var/tv/recordings/              |
| 10 | Default     | mythbox  | /var/mythtv/tv2/recordings/      |
| 11 | Default     | mythbox  | /var/mythtv/tv3/recordings/      |
| 14 | Default     | mythbox  | /var/tv2/recordings/             |
| 15 | Videos      | mythbox  | /var/mythtv/videos/              |
| 16 | Coverart    | mythbox  | /var/mythtv/artwork/coverart/    |
| 17 | Fanart      | mythbox  | /var/mythtv/artwork/fanart/      |
| 18 | Screenshots | mythbox  | /var/mythtv/artwork/screenshots/ |
| 19 | Banners     | mythbox  | /var/mythtv/artwork/banners/     |
+----+-------------+----------+----------------------------------+

He requested that I run the backend with the parameters -v file,schedule --loglevel debug. The error appeared pretty quickly. I have attached the log file.

I cut off the log file right after the error appeared. Please let me know if you need any additional information.

Attachments (1)

mythbackend.log (974.2 KB) - added by bob@… 7 years ago.
mythbackend log with -v file,schedule --loglevel debug

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by bob@…

Attachment: mythbackend.log added

mythbackend log with -v file,schedule --loglevel debug

comment:1 Changed 7 years ago by Raymond Wagner

Description: modified (diff)

comment:2 Changed 7 years ago by sphery

Owner: changed from danielk to sphery
Status: newassigned

comment:3 Changed 7 years ago by sphery

bob, to work around this bug, please use any Storage Group disk scheduler other than Balanced Free Space. Combination would probably be a good choice that's not too different from Balanced Free Space. See http://www.mythtv.org/wiki/Storage_Groups#Storage_Group_Disk_Scheduler for more information on the available disk schedulers.

I'll get a fix in as soon as I get a chance.

comment:4 Changed 7 years ago by bob@…

Thanks for looking at this, I really appreciate it. I'm on 0.26 now and still having the issue. I'll change the disk scheduler this weekend and see how things go.

Note: See TracTickets for help on using tickets.