Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11010 closed Bug Report - General (Invalid)

mythfrontend.real crashed with SIGSEGV in mpegts_push_section()

Reported by: Stephen Robertson <stephengrobertson@…> Owned by:
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

1.Start Mythfrontend 2.Start playback of a recording 3.Exit the recording 4.Start playback of another recording(doesn't matter if it is the same recording as in 2) 5.Recording will not start and mythfrontend crashes.

Attachments (4)

version.txt (881 bytes) - added by Stephen Robertson <stephengrobertson@…> 7 years ago.
--version info
Stacktrace.txt (27.1 KB) - added by Stephen Robertson <stephengrobertson@…> 7 years ago.
var.log.mythtv.mythbackend.log.txt (524.5 KB) - added by Stephen Robertson <stephengrobertson@…> 7 years ago.
trimmed.var.log.mythfrontemd.log.txt (89.1 KB) - added by Stephen Robertson <stephengrobertson@…> 7 years ago.

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by Stephen Robertson <stephengrobertson@…>

Attachment: version.txt added

--version info

comment:1 Changed 7 years ago by Stephen Robertson <stephengrobertson@…>

Changed 7 years ago by Stephen Robertson <stephengrobertson@…>

Attachment: Stacktrace.txt added

Changed 7 years ago by Stephen Robertson <stephengrobertson@…>

Changed 7 years ago by Stephen Robertson <stephengrobertson@…>

comment:2 Changed 7 years ago by Stephen Robertson <stephengrobertson@…>

Apologies this may be a red herring. On further investigation my system still had 0.25 libraries installed so the problem is with the ubuntu upgrade process. I have seen an occasional problem after removing the errant lib but that is likely unrelated to this backtrace. I'll investigate and if appropriate raise a new ticket. Apologies for the noise.

comment:3 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Resolution: Invalid
Status: newclosed

Thank you for reporting back.

comment:4 Changed 7 years ago by Stephen Robertson <stephengrobertson@…>

It turns out that was just coincidence that the problem went away after removing the 0.25 lib. Ubuntu generated a new bug report https://bugs.launchpad.net/mythbuntu/+bug/1038746. I'm not proficient enough to tell if these reports are different bugs or just two instances of the same thing.

comment:5 Changed 7 years ago by jksjdevelop@…

I am experiencing the same issue in myth 0.26 beta. Similarly I have failed to refine the problem into a repeatable event. I am also located in the UK and receive dvb-t2. I am experiencing the problem about every other day but most of the stuff I watch is HD and I think it only occurs on SD recordings, I will monitor carefully from now on

Note: See TracTickets for help on using tickets.