Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11280 closed Bug Report - General (Invalid)

backend wrongly mentions Empty LocalHostName.

Reported by: udovdh@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.26-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When we verbatim use the new config.xml as exampled at http://code.mythtv.org/trac/browser/mythtv/mythtv/contrib/config_files/config.xml?rev=16b232a The backand does not really mention the LocalHostName? as it was configured in the config.xml when starting up. Instead it mentions: Empty LocalHostName?. This is wrong as we can see in the config.xml we just described. Backend should use the LocalHostName?. Next it should continue; when it can't find BackEndIP in the database it should error more descriptively: can't find BackEndIP belonging to $LocalHostName? when it starts looking for the rest of the configuration. Due to this the backend also thinks it cannot upgrade the database, citing other backends are active. mythtv-setup DOES upgrade the database.

Change History (9)

comment:1 Changed 7 years ago by Raymond Wagner

Resolution: Invalid
Status: newclosed

I can't actually find any bug in the program being described here. Everything seems to be intended behavior.

comment:2 Changed 7 years ago by udovdh@…

I _did_ SET a LocalHostName? but the programs claims it is empty. Of course in the USA that is not enough reason to do anything about reality. (nothing personal) I set LocalHostName? is BLA Backend says it is empty. Q.E.D.

BTW: backend leaks.

comment:3 Changed 7 years ago by Raymond Wagner

Does that mean in the Netherlands, you can't be bothered to properly explain your problem? If you were using the default config.xml verbatim, as stated, you would have had the line...

<LocalHostName?>my-unique-identifier-goes-here</LocalHostName?>

... which is specially interpreted by the code reading that file as having no defined identifier. It should say the LocalHostName? value is empty, and it should go on to use he default, which is the system hostname.

As for your second issue, having no IP defined is an invalid configuration for a backend, and it will automatically terminate. Following from your previous issue, if the selected profile (or LocalHostName?) is incorrect, it would be pulling your configuration from the wrong profile, and explain why it would refuse to operate. Is there any chance you ran mythtv-setup and mythbackend under different user accounts, or otherwise different environments, perhaps as a result of the behavior of your init scripts, such that they would end up pulling their config.xmls from separate directories?

comment:4 Changed 7 years ago by udovdh@…

It did have a defined identifier! See the example which I verbatim used for this trial. Do you imply that the backend could not find this in e.g. teh josts file? Then make it say so! And do not say it is empty because that shows the level at whoch the software works, for developers, and not yet for users to comprehend. The second issue is closely related to this one but the software does not make that clear. It tries to outguess the user/admin and still fails, leaving no real clue. The clue giving is what can be improved greatly here. Now I did explain it for the third time. Please fix.

comment:5 in reply to:  4 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Priority: majorminor

Replying to udovdh@…:

It did have a defined identifier! See the example which I verbatim used for this trial.

As previously stated, the example you gave will result in the error you described, so that is expected behaviour.

Do you imply that the backend could not find this in e.g. teh josts file?

No, please read comment 3 again, you were given several hints to why your system is misconfigured, but you chose to ignore these hints. Hence we cannot help you, if you don't want to be helped.

Now I did explain it for the third time. Please fix.

I'm not on your payroll, neither are any of the other developers AFAIK. If you want someone to look at your issues, you need to change your attitude (I'm not only talking about this ticket, I'm talking about your tickets and your mails in general). Being offensive or sarcastic is not the way forward when the people trying to help you are doing it voluntarily in their spare time.

comment:6 Changed 7 years ago by udovdh@…

It might be expected behaviour but it is wrong and unhelpful as I already explained.

I fill LocalHostName? in config.xml. The software simply discards the value for some reason and says LocalHostName? is empty. Exactly THAT is wrong. Because the system is 'misconfigured' as you write we need better messages than this when the backend does stuff behind the smokescreens. It should say that the LocalHostName? is invalid. It should say that the LocalHostName? is not found in /etc/hosts or wherever. Or say whatever explaining why the input from config.xml (easy human-friendly format... NOT!) is not acceptible. See the 80/20 rule: 20% is functional code, the rest is errorchecking and errorhandling.

Please skip the mantra. You know the code is sloppy. And it shows here again. I offered to pay to fix stuff in the past. I even paid for feature. So what about it? There's issues like this one. There's probably still leaks.

And please do not forget that english, let alone, ameriglish, is not my first lanuguage.

I will not spend any time on this blatant issue.

comment:7 Changed 7 years ago by dekarl@…

The real question is, what are you trying to achieve by manually creating a config.xml? I just let it automatically generate on first start and everything just works.

The generated config.xml has a LocalHostName? (override) of "my-unique-identifier-goes-here" and the corresponding notice (which could use a rewording but thats another topic), too.

Dec 09 09:36:11 mythmaster mythfrontend[2073]: N CoreContext? mythcontext.cpp:491 (LoadDatabaseSettings?) Empty LocalHostName?.

Looking at the mailing list you seem to be using a dedicated physical machine. Just using Mythbuntu might be an option to get to a known good base installation. (it worked for me, comes with all kinds of configuration adjustments, like php memory limit, binding mysql to the network, etc.)

comment:8 in reply to:  6 Changed 7 years ago by Kenni Lund [kenni a kelu dot dk]

Replying to udovdh@…:

It might be expected behaviour but it is wrong and unhelpful as I already explained.

From the information provided in this ticket, it could just as well be right. You were asked in comment 3 if you by chance were starting mythtv under different user accounts and/or different environments. If so, you could just as well be editing the wrong config.xml file, in which case, the warning given is correct. But when you don't reply with the information requested, it's very hard for us to help you.

comment:9 Changed 7 years ago by udovdh@…

See http://www.mythtv.org/wiki/Release_Notes_-_0.26. Where does it say: just remove the old one and voila?

What do you want to say with the log-style stuff? You keep using my time by not fixing this. Just make it say the localhostname is not usable. (!!!) The config.xml was valid and OK. See the mailinglist.

Focussing on a different distro means you do not get it at all. It is the errorhandling of the backend that needs fixing as it is the most trivial.

You do not see that as necessary for weird reasons beyond understanding by my simple soul. Now please fix the issue and only bother me when it is fixed.

Note: See TracTickets for help on using tickets.