Opened 14 years ago

Closed 14 years ago

#1130 closed patch (duplicate)

signed/unsiged char warns in libs/libmythtv/channelutil.cpp:insert_dtv_multiplex() for ppc

Reported by: jwestfall@… Owned by: Isaac Richards
Priority: minor Milestone: 0.19
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

channelutil.cpp: In function `bool insert_dtv_multiplex(int, QString, uint, QStr
ing, int, int, bool, int, char, char, char, char, QString, QString, char, QStrin
g, QString, QString)':
channelutil.cpp:47: warning: comparison is always true due to limited range of d
ata type
channelutil.cpp: In static member function `static int ChannelUtil::CreateMultip
lex(int, const QString&, uint, const QString&)':
channelutil.cpp:102: warning: passing negative value `-0x00000000000000001' for 
converting 9 of `bool insert_dtv_multiplex(int, QString, uint, QString, int, int
, bool, int, char, char, char, char, QString, QString, char, QString, QString, Q
String)'

etc

Attachments (1)

channelutil.diff (1.2 KB) - added by jwestfall@… 14 years ago.

Download all attachments as: .zip

Change History (2)

Changed 14 years ago by jwestfall@…

Attachment: channelutil.diff added

comment:1 Changed 14 years ago by danielk

Resolution: duplicate
Status: newclosed

duplicate of #994

Note: See TracTickets for help on using tickets.