Opened 6 years ago

Closed 6 years ago

#11305 closed Bug Report - General (Works for me)

Playback of home made DVDs from Toshiba rd-xs34 recorder stutters.

Reported by: jactry@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - DVD Playback Version: 0.25.3
Severity: medium Keywords: stutter
Cc: Ticket locked: no

Description

I used to record movies with the rd-xs34 recorder/burner and never had any issue playing them on any DVD player. Recently I built a HTPC based on ASUS AT5IONT-I (nvidia GT218 ION2) and mythtv and discovered that only these DVDs have serious playback problem on this platform. They all stutter to a variable degree (video and audio), some of them being not watchable at all, yet playing flawlessly on other players. I have been a mythtv user for years but haven't used the DVD functionnality until now so I cannot tell if it's a regression bug. I can state some certain facts here:

  1. Codec used is hardware VDPAU. Nvidia drivers version: 304.64.
  2. No playback problem with DirectTV mpeg2, h264 mkv, etc.
  3. XBMC and OpenElec?, when booted to from a USB key, play these DVDs just normally. So does any dedicated player I tested so far.
  4. On mythtv, the problem can be worked around partially using a different decoder like VAAPI. Doing so improves playback very much but does not solve it entirely as playback pauses or picture goes blank from time to time. It also uses more CPU than VDPAU. The attached logs are obtained from the same part of "The Matrix" tested with VDPAU and VAAPI.
  5. Commercial DVDs playback is superb (using VDPAU) and the DVD menu stuttering problem observed recently appears to be gone.
  6. Different deinterlacer settings have no effect at all.

I am willing to do any required test or extract a video sample to help the mythtv team solving this.

Attachments (1)

mythfrontend_log.zip (9.5 KB) - added by jactry@… 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by jactry@…

Attachment: mythfrontend_log.zip added

comment:1 Changed 6 years ago by stuartm

Resolution: Works for me
Status: newclosed

This has already been fixed, you need to upgrade.

Note: See TracTickets for help on using tickets.