Opened 7 years ago

Closed 6 years ago

#11400 closed Bug Report - General (Need more Info)

HLS Audio Sync

Reported by: bryan.l.johnson@… Owned by: cpinkham
Priority: minor Milestone: 0.27
Component: MythTV - HTTP Streaming Version: 0.25.3
Severity: medium Keywords: HLS
Cc: Ticket locked: no

Description

I just upgraded to .25 on mythbuntu 12.04 and the HTTP live streaming is a very cool feature. I am having one issue. I have a hauppauge 1600 that I am capturing QAM content with. The shows play fine on my front ends but when I watch them with HLS the sound gets out of sync. The audio is always ahead of the video. its so bad the shows are unwatchable. I have tried every audio and video encode option in the API sample pages and get the same results. The SD content I have works just fine. It looks like the FFMpeg library has tools to fix this audio sync issue but there isn't a way to specify the switches in the currenlty HLS setup. The other transcoding areas has automatic media detection and profiles. Can another transloading profile be added for this?

Change History (4)

comment:1 Changed 6 years ago by paulh

Milestone: 0.28

comment:2 Changed 6 years ago by Kenni Lund [kenni a kelu dot dk]

Type: Developer TaskBug Report - General

comment:3 Changed 6 years ago by paulh

Status: newinfoneeded_new

Can you please retest with master since we've had multiple ffmpeg updates since 0.25 and the audio code has undergone major revisions since then.

comment:4 Changed 6 years ago by stuartm

Milestone: 0.280.27
Resolution: Need more Info
Status: infoneeded_newclosed

No response to request for information after 6 weeks.

Note: See TracTickets for help on using tickets.