Opened 6 years ago

Closed 6 years ago

#11428 closed Bug Report - General (Unverified)

Unable to play music after successful rip

Reported by: pmunly@… Owned by:
Priority: minor Milestone: unknown
Component: Plugin - MythMusic Version: 0.26-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

After ripping/encoding to FLAC via MythMusic I was unable to play the songs which were ripped/encoded. I managed to determine the issue, and fix it so I am able to play the songs, however I believe this is a bug. I am going to describe the situation and the steps I took, which should have fixed the issue, and what I ended up having to do to get the music working.

Situation - I originally had the same CD ripped/encoded to OGG and have been converting my music to FLAC. MythMusic was able to play the OGG files with no issues. Initially I removed the original OGG files and directory. Next I ripped/encoded the CD into FLAC. Prior to performing the rip/encode, I was given the option to delete the original OGG files in the database and replace with the newly encoded files. I chose the "Delete All" option. After the rip/encode was complete, I attempted to add the files to the playlist and play them. Adding the files to the playlist worked, however playing the files did not. I tried deleting the entire music database and re-scanning for new music, which completed, but the files still would not play. After checking the mythfrontend.log file, I noticed when adding the new FLAC files, I received the following error:

mythfrontend[3713]: E CoreContext? metadata.cpp:649 (Filename) Metadata: Asked to get the filename for a track but no file found: Dream Theater/A Dramatic Turn of Events/01 - On the Backs of Angels.flac

The same error occurred for each song on the album, leading me to realize the "of" in "A Dramatic Turn of Events" did not match with the actual directory structure - the directory created by MythMusic during the rip/encode had an "Of" with an uppercase "O" instead of the lowercase. After changing the directory name to include the lowercase "o" instead of the upper, the songs played. My best guess at this point is that the original OGG files I had in the database were located in a folder with a lowercase "o" instead of an uppercase "O" and for some reason the database was not entirely cleared out when I tried to delete the music database. The ID3 tags associated with the new FLAC files all have an uppercase "O" in the "Of" and reflect that in MythMusic when browsing or playing the files.

Change History (2)

comment:1 Changed 6 years ago by paulh <mythtv@…>

Can you confirm you are actually using 0.26-fixes?

This sounds like a bug that was fixed some time ago here http://code.mythtv.org/trac/changeset/cfdd72e88d

comment:2 Changed 6 years ago by paulh

Resolution: Unverified
Status: newclosed

No reply in 7 weeks. I suspect this was already fixed in [cfdd72e88d].

Please re-open if you can still reproduce this with current 0.26-fixes or master.

Note: See TracTickets for help on using tickets.