Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#11564 closed Patch - Feature (fixed)

Feature patch to increase read size in hdhrstreamhandler.cpp

Reported by: Gary Buhrmaster <gary.buhrmaster@…> Owned by: Gary Buhrmaster <gary.buhrmaster@…>
Priority: minor Milestone: 29.0
Component: MythTV - HDHomeRun Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In ticket #10414 ( patch http://code.mythtv.org/trac/changeset/2be3dd91fba8d438cb25d81a1ba9d0d5e8657fb6/mythtv ) the patch increased the buffersize for the hdhr. This was ineffective in that patch, since that particular variable was no longer used. This patch increases the maximum returned read size to be 1/8 of a second of potential buffer (implementing, partially, what I believe the original ticket was intended to do). With the presumption that the loop *is* executed around 20 ms (the usleep counter) the current 64KB read limit, with a high bitrate stream (which can produce ~100KB in 20ms), can result in 3 or 4 calls through the hdhr library to read all the buffered data. Increasing the amount of data to examine to the 1/8 second value (~300KB) results in reducing the number of calls to 2 or 3 potentially reducing the lock overheads (whether it is the higher value will depend on whether a new packet arrived while processing the existing set of packets, and lower bitrate content (a more common case) will show no improvement).

Patch:

https://github.com/garybuhrmaster/mythtv/commit/e25720a96f35d794209f5b0f3369086e187756ff

Change History (6)

comment:1 Changed 6 years ago by stuartm

Component: MythTV - DVBMythTV - HDHomeRun
Owner: changed from danielk to Silicondust

comment:2 Changed 6 years ago by gary.buhrmaster@…

Should the assignment not remain with danielk, since it is his previous code that added and then deleted the buffer adjustments (that were ineffective for other reasons) that this patch is attempting to (re)implement, so he is probably the most knowledgeable about this code fragment?

comment:3 Changed 6 years ago by stuartm

Owner: changed from Silicondust to danielk
Status: newassigned

The reassignment was automatic with the change of component.

comment:4 Changed 4 years ago by Stuart Auchterlonie

Owner: danielk deleted
Status: assignednew

comment:5 Changed 4 years ago by Gary Buhrmaster <gary.buhrmaster@…>

Owner: set to Gary Buhrmaster <gary.buhrmaster@…>
Resolution: fixed
Status: newclosed

In c0b1e6b242ee17000af45780cc96c2cd6c0606fc/mythtv:

Patch to increase hdhr max returned buffer size

In (very) high bitrate scenerios, the 64KB value may
result in extra traffic through the various library
routines (since in 20ms, 100KB could be seen). This
patch increased the buffer size a bit.

(cherry picked from commit e25720a96f35d794209f5b0f3369086e187756ff)
Signed-off-by: Karl Dietz <dekarl@…>

replaces a magic number

Fixes #11564

comment:6 Changed 4 years ago by Karl Egly

Milestone: unknown29.0
Note: See TracTickets for help on using tickets.