Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11666 closed Bug Report - General (fixed)

Starting mythfrontend with the -p option causes it to use 100% cpu

Reported by: paulh Owned by: JYA
Priority: critical Milestone: 0.27.1
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

To reproduce

  • start the FE with mythfrontend -p
  • choose your language and save
  • select your backend and save

the FE restarts but uses 100% cpu

Attachments (1)

bt11666.txt (16.4 KB) - added by paulh 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by gigem

Milestone: unknown0.27
Resolution: Works for me
Status: newclosed

This issue appears to have been resolved as a result of some other changes since I can no longer reproduce it in master.

comment:2 Changed 6 years ago by gigem

Priority: minorblocker
Resolution: Works for me
Status: closednew

Paul Harrison says he can still reproduce the problem.

Changed 6 years ago by paulh

Attachment: bt11666.txt added

comment:3 Changed 6 years ago by paulh

The attached bt was captured by attaching to the frontend and pressing Ctrl-C while it was running at 100% cpu.

htop says pid 25260 is the thread running at 100% which is thread #1 in the bt.

comment:4 Changed 6 years ago by JYA

seeing the same thing here on a mac build.

However, after about 5 minutes, it starts to go down..

comment:5 Changed 6 years ago by stuartm

Milestone: 0.270.27.1
Priority: blockercritical

comment:6 Changed 6 years ago by JYA

Owner: set to JYA
Status: newassigned

comment:7 Changed 6 years ago by Jean-Yves Avenard <jyavenard@…>

Resolution: fixed
Status: assignedclosed

In 0db22a0f99cb9eeef3cf9f40e1f71a161a4e767c/mythtv:

Use QEventLoop for modal windows.

According to the Qt forums, you can call qApp->exec() only once per application, otherwise weird things occur. In particular 100% CPU usage.

Fixes #11666

comment:8 Changed 6 years ago by Jean-Yves Avenard <jyavenard@…>

In 492224b291b3568a3f59622112920769a6e82a83/mythtv:

Use QEventLoop for modal windows.

According to the Qt forums, you can call qApp->exec() only once per application, otherwise weird things occur. In particular 100% CPU usage.

Fixes #11666
(cherry picked from commit 0db22a0f99cb9eeef3cf9f40e1f71a161a4e767c)

Note: See TracTickets for help on using tickets.