Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 9 months ago

Closed 9 months ago

#11682 closed Bug Report - General (fixed)

Commit f2b2e0fae2d breaks .srt subs

Reported by: Yianni Vidalis <yiannividalis@…> Owned by: stichnot
Priority: minor Milestone: 0.27
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

As discussed in the users list (http://www.gossamer-threads.com/lists/mythtv/users/547283).

External .srt subs show ok up and until c691ddf5368564. From feb2e0fae2dc7e163cffd004da92d7654765fa1f onwards, no external .srt subs are shown.

As per Jim Stichnoth's request, I will attach the relevant logs, performed by mythavtest (with -v playback,network,vbi).
I hope it helps.

Attachments (2)

mythavtest.20130714163211.12004-no-subs-feb2e0fae2dc7e.log (42.8 KB) - added by Yianni Vidalis <yiannividalis@…> 9 months ago.
mythavtest.20130714161945.16599-subs-ok-c691ddf5368564.log (43.7 KB) - added by Yianni Vidalis <yiannividalis@…> 9 months ago.

Download all attachments as: .zip

Change History (4)

Changed 9 months ago by Yianni Vidalis <yiannividalis@…>

Changed 9 months ago by Yianni Vidalis <yiannividalis@…>

comment:1 Changed 9 months ago by stichnot

  • Milestone changed from unknown to 0.27
  • Owner set to stichnot
  • Status changed from new to accepted

comment:2 Changed 9 months ago by Jim Stichnoth <jstichnoth@…>

  • Resolution set to fixed
  • Status changed from accepted to closed

In 34a1a8a4fcee33ca3a56700cc9864c19dbc296f4/mythtv:

Allow local .srt files to be loaded. Regression in feb2e0f.

Fixes #11682. The problem was that when the subtitle loading
mechanism was changed from a FileRingBuffer? to a RemoteFile?, the
RemoteFile? mechanism doesn't work for local files, such as in a
combined BE/FE system.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.