Opened 13 years ago

Closed 13 years ago

#1170 closed enhancement (invalid)

mythvideo, gallery view behaviour change

Reported by: mythtv.cvs@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by danielk)

MythVideo? has had a feature altered/removed, and it has impacted performance significantly. Many MythVideo? users have an organized file heirarchy in their video directory. Previously, it was not necessary to have "video gallery browses files" on, in order to get a listing of directories and subdirectories to show up in the MythTV gallery-style view.

Put another way, I have 1943 video files currently in my video directly. TV shows, movies, etc. Before this change took place, I was able to enter MythVideo? in 1-2 seconds. Now, after being forced to turn on "video gallery browses files" in order to get this type of view, I need to wait 42 seconds to enter MythVideo?. This time is quite excessive. :/

I am hoping that someone can restore the functionality that 0.18.x had, where one could have a gallery-style view of a video tree, without having to scan the directory for new files...

Change History (4)

comment:1 Changed 13 years ago by danielk

Description: modified (diff)
Resolution: invalid
Status: newclosed

Feature request without patch [invalid].

I don't understand the complaint anyway, if 'video gallery browses files' is the behaviour you want, why don't you just check that check box? Please, reply in mailing list.

comment:2 Changed 13 years ago by mythtv.cvs@…

Resolution: invalid
Status: closedreopened

I've replied to the list, but I'm not a member so I am not sure if it will ever make it through.

I don't want to use "video gallery browses files". As I say above, it was previously not necessary to have this option on, in order to have a non-flat listing of files.

Now, I must turn this option on in order to get a Gallery that lists files and directories as well. This results in a 42 second delay from when I select MythVideo?... to when I finally get a listing.

Before, the delay was 1-2 seconds, with Myth0.18.1. It allowed one to browse directories, listed in the SQL database, without looking at the filesystem itself. I'm not sure how else to explain this.

Since you weren't quite sure what I was talking about before, I've re-opened this ticket. I think a 42 second pause before entering MythVideo? is a bit excessive. Part of the problem is that a feature has been merged with another feature.

I could provide a patch that makes MythVideo?'s gallery view always view the full tree, instead of flat only...

comment:3 Changed 13 years ago by danielk

Milestone: 0.190.20
Owner: changed from Isaac Richards to danielk
Status: reopenednew
Type: defectenhancement
Version: head

Ok, this sounds resonable.

Reopen this when you have the patch ready and I'll look over it.

Try to make the configuration panel a little simpler if you can. It is a little confusing as is. Not such a big deal with the number of options in there now, but we all know that configuration panel will grow...

comment:4 Changed 13 years ago by danielk

Resolution: invalid
Status: newclosed

invalid until patch added.

Note: See TracTickets for help on using tickets.