Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#11877 closed Bug Report - Hang/Deadlock (fixed)

Asking track to immediate play hangs FE

Reported by: warpme@… Owned by: Paul Harrison <pharrison@…>
Priority: minor Milestone: 0.28
Component: Plugin - MythMusic Version: 0.27-fixes
Severity: medium Keywords: mythmusic
Cc: Ticket locked: no

Description

I'm on current 0.27-fixes. When I'm trying to immediately play a song FE hangs (no any reaction for KBD/mouse/remote). Steps to reproduce:

1.Start mythmusic

2.Select "Switch view/Play editor tree"

3.Go to "Directory/<album>/<track>"

4.Press "p" on KBD or Play on remote

5.FE hangs.

6.Only killall -9 helps.

FE log and trace from hanging FE attached. Beside this issue with - all other mythmusic functions are working OK for me.

Attachments (2)

fe.log.zip (403.2 KB) - added by warpme@… 6 years ago.
FE log
trace.log (10.7 KB) - added by warpme@… 6 years ago.
trace

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by warpme@…

Attachment: fe.log.zip added

FE log

Changed 6 years ago by warpme@…

Attachment: trace.log added

trace

comment:1 Changed 6 years ago by paulh

I can't reproduce this.

What keybinding is 'p' bound to PLAY or PAUSE?

When you do this are there tracks in the active playlist already?

Is the music already playing or stopped when you do this?

Is this in the cross compiled build that I seem to remember you having problems with before that no one could reproduce?

comment:2 Changed 6 years ago by warpme@…

Paul,

What keybinding is 'p' bound to PLAY or PAUSE?

I do test with VNC and pressing key P on KBD and also witch remote where PLAY and PAUSE are mapped to "P". It doesn't matter

When you do this are there tracks in the active playlist already?

Yes and they are playing.

Is the music already playing or stopped when you do this?

It is playing.

Is this in the cross compiled build that I seem to remember you having problems with before that no one could reproduce?

Yes. This is cross-compiled build.

Indeed, in past I had problem with no sound on AAC/AAC+ radio streams under 0.27. Interestingly - it disappeared since some commits in 0.27 and now all works perfectly. (FYI: during that period of time only mythtv code was changed so I believe AAC issue was somehow related to mythtv).

FYI: I do test on 2 different cross-compiled images (32bit pentium-mmx target with Qt4.8.5) and (64bit ATOM target with Qt4.8.2) - both have issue.

comment:3 Changed 6 years ago by paulh

Resolution: Works for me
Status: newclosed

Works for me and no one else has reported any problems.

comment:4 Changed 5 years ago by Jonatan Lindblad

Resolution: Works for me
Status: closednew

The error seems to be triggered if the visualizer widget is present in the playlist editor. The MythMediStream? Redux theme have the visualizer there and can be used to reproduce the error.

comment:5 Changed 5 years ago by warpme@…

natanojl - thx for quick response. In fact I had plan to post here that removing visualiser from playlist editor 'solves' issue but You were faster :-)))) I'm not sure is having visualiser in playlist editor simply prohibited by design, or rather all this exposure bug.... Nevertheless many ppl will be happy for not freezing FE.... Anyway thx for quick response!

comment:6 Changed 5 years ago by Paul Harrison <pharrison@…>

Owner: set to Paul Harrison <pharrison@…>
Resolution: fixed
Status: newclosed

In 35c0baccfc2012b10dc8cfd81555baf1af156d6b/mythtv:

MythMusic: Fix crash when using immediate play in the playlist editor

If the playlist editor has a visualiser and PLAY is pressed when the playlist
tree has focus results in a crash. This works around the problem by shutting
down the visualiser before loading and playing the new tracks. Fixes #11877.

comment:7 Changed 5 years ago by paulh

Milestone: unknown0.28

Please report back if this fixes the issue for you I couldn't reproduce the hang but did manage to get it to crash.

comment:8 Changed 5 years ago by warpme@…

Paul, I do tests with v0.28-pre-2502-gdbefda7 and unfortunately issue is still present. Now however it is little more difficult to trigger it...I have to enter playlist editor then gallery view then tree view. Now - 1st attempt to play track plays OK but attempt to play another track freezes UI with mythfrontend process consuming 100% CPU. Interesting is that killall X kills Xserver, but mythfrontend process still exist and get all CPU...

Note: See TracTickets for help on using tickets.