Opened 6 years ago

Closed 4 years ago

#11951 closed Bug Report - General (Unverified)

MythTV 0.26 find_orphans.py not working

Reported by: bob.havlin@… Owned by: sphery
Priority: minor Milestone: unknown
Component: Contributed Scripts & Apps Version: 0.26-fixes
Severity: medium Keywords: find_orphans.py python orphans
Cc: Ticket locked: no

Description

I have previously used this script successfully, and it worked well (even on 0.26). This time, after a drive failure, I have a lot of missing recordings that I wanted to clean up. I run the script and get the following message:

./find_orphans.py

Traceback (most recent call last):
  File "./find_orphans.py", line 230, in <module>
    main()
  File "./find_orphans.py", line 166, in main
    recs, zerorecs, orphvids, orphimgs, dbbackup, unfiltered = populate(host)
  File "./find_orphans.py", line 84, in populate
    recs = list(DB.searchRecorded(**kwargs))
  File "/usr/lib/python2.7/dist-packages/MythTV/utility/other.py", line 180, in __call__
    yield self.handler.fromRaw(row, db=self.inst)
  File "/usr/lib/python2.7/dist-packages/MythTV/database.py", line 131, in fromRaw
    dbdata._evalwheredat()
  File "/usr/lib/python2.7/dist-packages/MythTV/database.py", line 307, in _evalwheredat
    DBData._evalwheredat(self, wheredat)
  File "/usr/lib/python2.7/dist-packages/MythTV/database.py", line 145, in _evalwheredat
    self._wheredat = eval(self._setwheredat)
  File "<string>", line 0
    
    ^
SyntaxError: unexpected EOF while parsing

Looks like there is a python issue - this is also supported by the fact that I get an error when I run mythpython --version:

/usr/bin/mythpython --version

Traceback (most recent call last):
  File "/usr/bin/mythpython", line 15, in <module>
    import MythTV.tmdb.tmdb_api
ImportError: No module named tmdb.tmdb_api

If I change the following lines to include the "3" in tmdb (as is the proper directory name for: /usr/lib/python2.7/dist-packages/MythTV/tmdb3/) - it works as is shown in attached.

import MythTV.tmdb3.tmdb_api ... print_version('tmdb version', MythTV.tmdb3.tmdb_api.version)

Nevertheless, the original problem of find_orphans.py remains and the offending recs = list(DB.searchRecorded(* *kwargs)) statement

Any ideas what is the problem here?

Attachments (1)

mythtv-find_orphans-details.txt (4.1 KB) - added by bob.havlin@… 6 years ago.
mythtv version, mythpython version, installed packages

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by bob.havlin@…

mythtv version, mythpython version, installed packages

comment:1 Changed 6 years ago by bob.havlin@…

Also:

python --version Python 2.7.3

comment:2 Changed 6 years ago by bob.havlin@…

Just did a partial restore of the mythconverg database and now find_orphans.py is working. Not sure of the cause, but there was no indication of a DB problem from the script.

comment:3 Changed 4 years ago by Karl Egly

Resolution: Unverified
Status: newclosed

Sorry for taking so long to get at this ticket. As this appears to have been a one off issue that has not reappeared I'm closing this ticket.

Note: See TracTickets for help on using tickets.