Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#11990 closed Bug Report - General (fixed)

Mythtv-setup ignores keyboard input

Reported by: Craig Treleaven <ctreleaven@…> Owned by: JYA
Priority: minor Milestone: 0.27.1
Component: Ports - OSX Version: 0.27-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Ref: http://code.mythtv.org/trac/ticket/10587

As in the ticket above, mythtv-setup stops accepting keyboard input on the *second* pop-up dialog while doing a channel scan on the HDHomerun. (See description of steps at <http://www.mythtv.org/wiki/Backend_Mac_OS_X_USA_HDHR_Setup#Menu_5:_Input_Connections>.

As described in #10587, mouse input still works and allows the user to complete configuring the device. While this is a workaround, it is extremely confusing for new users.

Screen capture of the non-responsive dialog is at: <https://www.dropbox.com/s/3gimhuucktvb9wx/ChannelScan_2_2013Dec05.jpg>

Issue occurs with 0.27-fixes produced by either the official packaging script or with MacPorts?.

...

Wild conjecture on my part but I wonder if this is the issue that causes some Myth Plugins (MythBrowser?, etc) to be non-functional on OS X. I haven't tested recently but as I recall, the plugin would launch but then become non-responsive. If there are some sort of tests that would help narrow down the issue, I would be glad to help.

Attachments (1)

mythtv-setup_version_info.txt (623 bytes) - added by Craig Treleaven <ctreleaven@…> 6 years ago.
avenard.org app -- version details

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by Craig Treleaven <ctreleaven@…>

avenard.org app -- version details

comment:1 Changed 6 years ago by Craig Treleaven <ctreleaven@…>

Ping, 2 weeks...no acknowledgement?

comment:2 Changed 6 years ago by JYA

It's a qt bug, one that I can only reproduce on mac... I've hunted that one for weeks with no luck

comment:3 Changed 6 years ago by Craig Treleaven <ctreleaven@…>

Is there a qt bug I can follow?

BTW, I just noticed in #10587 the comment that the issue only occurs with llvm and clang. Do you still believe that to be the case? In MacPorts?, I can force using gcc (even with recent versions of XCode). Let me know and I'll rebuild and test.

To fix (workaround?) 10587, the changeset modified mythmainwindow.cpp. It seems to me that the specific bug I'm experiencing is due to two pop-up dialogs in a row. I haven't even been able to find the HDHomerun channel scanner; let alone where the two pop-ups get called. Have you looked at the code in question; is the same sort of fix/workaround not possible?

http://code.mythtv.org/trac/changeset/995db9d284a40d695271302a0fa812d9353b9faa/mythtv

comment:4 Changed 6 years ago by JYA

I can't make a simple code that would reproduce the issue. gcc doesn't exist on mac by default and hasn't been provided by apple for years; at best it's just a llvm backed gcc; not the real gcc

if you can find a fix good on you, but I haven't managed to make a permanent fix. Every time I had a fix fixing a particular issue a similar one pop-up later.. it never ends

comment:5 Changed 6 years ago by Craig Treleaven <ctreleaven@…>

Re gcc, that's why I specified MacPorts?:

https://trac.macports.org/browser/trunk/dports/lang/apple-gcc42/Portfile

Description: Apple's version of the GNU compiler collection, version 4.2. Supports C, Objective-C, and C++

I can force my myth ports to use this compiler if it will avoid the problem with the pop-ups. Virtually all folks using the backend from MacPorts? will be using HDHomerun devices so it is pretty important to me.

If I get some time tomorrow, I'll try building with gcc and see if it still exhibits the problem or not. I'll also ask the maintainer for MacPorts? qt4 ports to see if he can help.

BTW, I know Qt 5 support is a longer range plan. Does that mean after 0.28?

comment:6 Changed 6 years ago by Jean-Yves Avenard <jyavenard@…>

Resolution: fixed
Status: newclosed

In 9edb6d6c4aa0ed930be222ddd32cfc008d709d9f/mythtv:

Fix old Qt setting screens preventing them from accepting keyboard inputs

Hopefully this is the final fix…
The issue seems to only have occurred on macs. When opening two MythDialogs? (that includes MythPopup?) in a row, often the 2nd one would not accept any used input anymore, only causing a “beep”; making it impossible to even exit that window.

The existing logic (and there was nothing wrong with it) was to simply disable the current MythDialog? and put the new one on top of it. However, when doing so, somehow key events are now ignored.
So instead, we now disable all widgets within that MythDialog?, without disabling the dialog itself.

When doing so, the newly created MythDialog? is always working as expected.
This code should not be necessary, it is a workaround to what appears to be a Qt bug.

Fixes #11990.

comment:7 Changed 6 years ago by Jean-Yves Avenard <jyavenard@…>

In 39686c6c6800053fe25764d2f27cfdfc2dd21fab/mythtv:

Fix old Qt setting screens preventing them from accepting keyboard inputs

Hopefully this is the final fix…
The issue seems to only have occurred on macs. When opening two MythDialogs? (that includes MythPopup?) in a row, often the 2nd one would not accept any used input anymore, only causing a “beep”; making it impossible to even exit that window.

The existing logic (and there was nothing wrong with it) was to simply disable the current MythDialog? and put the new one on top of it. However, when doing so, somehow key events are now ignored.
So instead, we now disable all widgets within that MythDialog?, without disabling the dialog itself.

When doing so, the newly created MythDialog? is always working as expected.
This code should not be necessary, it is a workaround to what appears to be a Qt bug.

Fixes #11990.

(cherry picked from commit 9edb6d6c4aa0ed930be222ddd32cfc008d709d9f)

comment:8 Changed 5 years ago by paulh

Milestone: unknown0.27.1
Note: See TracTickets for help on using tickets.