Opened 6 years ago

Closed 6 years ago

#12018 closed Patch - Bug Fix (Duplicate)

Fix build for clang on FreeBSD 10.0

Reported by: Amar Takhar <verm@…> Owned by: Raymond Wagner
Priority: minor Milestone: unknown
Component: Ports - *BSD Version: Master Head
Severity: medium Keywords: clang, freebsd
Cc: Stuart Auchterlonie Ticket locked: no

Description

Various fixes on FreeBSD for clang.

I was unsure of how to handle some of these header includes if there are issues please let me know and I will re-submit.

Attachments (1)

0001-Fix-build-for-FreeBSD-10.0-clang.patch (3.6 KB) - added by Amar Takhar <verm@…> 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by Amar Takhar <verm@…>

comment:1 Changed 6 years ago by Raymond Wagner

Component: MythTV - GeneralPorts - *BSD
Owner: set to Raymond Wagner
Status: newaccepted

I'll take a look at this this weekend. I've been meaning to set up a 10rc buildbot for a while.

comment:2 Changed 6 years ago by Stuart Auchterlonie

Cc: Stuart Auchterlonie added

comment:3 Changed 6 years ago by Stuart Auchterlonie

While doing testing for my freebsd10 build slave i can confirm this patch resolves the build failures.

comment:4 Changed 6 years ago by Raymond Wagner

Resolution: Duplicate
Status: acceptedclosed

Since they're (nearly) the same patch, I'm going to close this ticket and just use #12020.

Note: See TracTickets for help on using tickets.