Opened 14 years ago

Closed 14 years ago

#1202 closed defect (worksforme)

Recording one episode that is followed by another will corrupt tv listing and crash

Reported by: anonymous Owned by: Isaac Richards
Priority: major Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by danielk)

About two days ago I reported how mythtv lost some TV recordings.

Well I've been able to reproduce it again. It always happens if there are two episodes in a row of a program..

Today, there was two episodes of "Charmed" playing in a row. Of course I will never admit that I wanted to watch and record this show and it was purely for testing purposes.

Anyway, there was one episode going from 8:30PM to 9:25PM and the other from 9:25PM to 10:20PM

In mythweb, in TV Listing I clicked on the first episode and selected "Record only this showing" and validated. Went back into TV listing, the second episode of charmed was gone from the list and the first one was now filling the time 8:30PM to 10:20PM

On clicking on this episode again, in the summary of the recording it said: "Fri, Feb 3 (Rerun) 08:30:00 PM to 10:20:00 PM (55 mins) (Search: IMDB - TV.com - Google )

As you can see, while it showed the timing to go from 8:30PM to 10:20PM, the length wasn't correct (55 minutes instead of 110 minutes) Going into the backend status page, it showed that encoder 1 was recording "" and that it would end at 9:20PM.

From there I went back into the TV Listing, and the two episodes listing were gone...

Then I had to do something, when I went back mythfront had crashed with a "Segmentation Fault".

Summary: each time I try to record a TV episode, that is followed by another one, things will get messy and sooner or later, mythfronted *will* crash.

sorry , I do not have the backtrace, I compiled mythtv without debugging

Change History (8)

comment:1 Changed 14 years ago by Isaac Richards

Description: modified (diff)
Resolution: invalid
Status: newclosed

No backtrace.

comment:2 Changed 14 years ago by anonymous

May I ask why it was changed to invalid? i can constistently reproduce this problem, and mythtv will crash7

comment:3 Changed 14 years ago by anonymous

sorry , I do not have the backtrace, I compiled mythtv without debugging

makes your report invalid.

comment:4 Changed 14 years ago by jyavenard@…

Resolution: invalid
Status: closedreopened

I understand that. However I re-opened a new bug where I do not report the segmentation fault that would happen after a while, but simply a bug that can be easily reproduced.

The TV listing becomes corrupted (the 2nd show disappear from the list) and it becomes impossible to record the 2nd show. Also the status of the recording in the recording list becomes incorrect, it shows the time of the two show combined : like from 8:30PM to 10:20PM while the lenght is shown as 55 minutes.

I believe this bug shouldn't be closed. Thank you for your understanding

comment:5 Changed 14 years ago by Spitfirer24@…

Just commenting as a user of Mythtv following the recent development on .19. While I can understand that lack of a backtrace makes this difficult to debug, I think this has to be fixed before release. It's a common occurence for a show to have two episodes in a row. Looking at my MythTV schedule now, I have three programs that are going to have episodes one after another. It's not going to be fun restarting the frontend after each show ends.

comment:6 Changed 14 years ago by danielk

Description: modified (diff)
Resolution: invalid
Status: reopenedclosed

Spitfirer24,

If someone says they can consistently reproduce a crash, but don't provide a backtrace there is nothing we can do; we must assume the reporter is up to no good unless we know them from prior experience.

The back-to-back programming recording problem is almost certainly due to common a configuration error, which he would know about if he searched the mailing lists.

comment:7 Changed 14 years ago by jyavenard@…

Resolution: invalid
Status: closedreopened

I did not write that I could consistently reproduce a crash, I wrote that I could consistently reproduce the 2nd show disappearing from the TV listing when the first show is being recorded.

Unfortunately, I do not have double episodes to play with in my mythtv installation, i have reproduced the mentioned problem for all double episodes listed for the next 2 weeks, so no more double episodes.

I was discussing this issue in a forum yesterday, and one person could reproduce this problem as well. So this is not a problem isolated on my system

Again, I am not reporting a crash I'm reporting a defect when recording two consecutive episodes. Systematically closing a bug is rather unfortunate when it can be easily reproduced without any backtrace

comment:8 Changed 14 years ago by Isaac Richards

Resolution: worksforme
Status: reopenedclosed

Can't reproduce.

Note: See TracTickets for help on using tickets.