Opened 5 years ago

Last modified 2 months ago

#12026 new Bug Report - General

MythArchive encoder gives high cpu load with zero progress

Reported by: J.Pilk@… Owned by: Paul Harrison <pharrison@…>
Priority: minor Milestone: 0.27.1
Component: Plugin - MythArchive Version: 0.27-fixes
Severity: medium Keywords: /mytharchive encoder_profiles
Cc: Ticket locked: no

Description

This has been reported for UK DVB-T2 and Comcast/ceton recordings. The cause appears to be the -copyts entry in the ffmpeg command line; the -r entry is probably unnecessary, too, and -b:v <value> seems to have little effect.

Often just -target ntsc-dvd or -target pal-dvd will give what is required.

http://www.gossamer-threads.com/lists/mythtv/users/561824#561824

Attachments (1)

ffmpeg.log (67.9 KB) - added by jreiser 2 months ago.
mythffmpeg inifinite loop at end of input: context, debug info, gdb traceback, debug log

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by J.Pilk@…

Reported again from the US. Deleting the -copyts line seems to have worked.

http://www.gossamer-threads.com/lists/mythtv/users/567922#567922

comment:2 Changed 5 years ago by Paul Harrison <pharrison@…>

Owner: set to Paul Harrison <pharrison@…>
Resolution: fixed
Status: newclosed

In b3c6b93176fb9998a7fe3ed120910ab2999ee1de/mythtv:

MythArchive?: Remove -copyts from the encoding profiles

There are reports this is causing more trouble than it fixes with current
ffmpeg. Fixes #12026.

comment:3 Changed 5 years ago by Paul Harrison <pharrison@…>

In ecb3f1f78041b2f4fbd84b32e2971809fe1b2ccc/mythtv:

MythArchive?: Remove -copyts from the encoding profiles

There are reports this is causing more trouble than it fixes with current
ffmpeg. Fixes #12026.

(cherry picked from commit b3c6b93176fb9998a7fe3ed120910ab2999ee1de)

comment:4 Changed 5 years ago by paulh

Milestone: unknown0.27.1

Changed 2 months ago by jreiser

Attachment: ffmpeg.log added

mythffmpeg inifinite loop at end of input: context, debug info, gdb traceback, debug log

comment:5 Changed 2 months ago by jreiser

Resolution: fixed
Status: closednew

This problem re-appears in mythtv-29.1+fixes.201812281328.af5d819~ubuntu18.04.1

The attachment above (ffmpeg.log) contains context, debug info, gdb traceback, and debug log (-debug_ts -v 48). The problem is reproducible every time on saved input (2183585792 bytes [2GB]).

If the cause cannot be identified and fixed, then it seems that a fail-safe could be detected by any one of:

  1. Processing of frames after the maximum number of frames in the duration of the scheduled recording.
  2. Processing more than 5 seconds of frames after End-Of-File on input.
  3. Processing more than 5 seconds of frames with no writes to output file.

comment:6 Changed 2 months ago by jpilk

I have a large collection of MythArchive? DVDs, but the last one was created in 2018 August and I suspect that it would take me some time to get back to an effective system based on current master.

I used only a small subset of the features offered. Any problem would cause failure with no easy way of re-using the results so far. So transcoding and cutting, if needed, were done first, and output was to an .iso file to be burned by K3B.

I rarely used HD input, but this sort of thing worked for me, for 1 video and 1 mp2 audio track. Rename the original recording to get it out of the way, and replace it.

ionice -c3 nice mythffmpeg -v "verbose" -i infile.xxx -target pal-dvd -qscale:v 3 -s 720x576 -acodec mp2 -b:a 192k -ac 2 -aspect 16:9 outfile.mpg

Note: See TracTickets for help on using tickets.