Opened 6 years ago

Closed 4 years ago

#12033 closed Bug Report - General (Fixed)

mythmetadatalookup --refresh-all-artwork started by housekeeping no longer runs in master.

Reported by: Bill Meek <keemllib@…> Owned by: Karl Egly
Priority: minor Milestone: 0.27
Component: MythTV - Housekeeper Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If the hostname for value 'DailyArtworkUpdates?' is set to a host (ofc0 in my case,) then housekeeping doesn't run mythmetadatalookup --refresh-all-artwork.

Changing the value of hostname to NULL re-enables --refresh-all-artwork.

The data field for both values of hostname equals '1'.

Attachments (1)

GoodArtworkRun.log (10.0 KB) - added by Bill Meek <keemllib@…> 6 years ago.
'Good' log and version: v0.28-pre-739-g7b9d369

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by Bill Meek <keemllib@…>

Attachment: GoodArtworkRun.log added

'Good' log and version: v0.28-pre-739-g7b9d369

comment:1 Changed 6 years ago by Raymond Wagner

Owner: set to Raymond Wagner
Status: newaccepted

comment:2 Changed 6 years ago by Raymond Wagner <rwagner@…>

In ffa364019e7d5bc0b88f4c83d21511090735b45d/mythtv:

Make "DailyArtworkUpdates?" a global option

This makes the DailyArtworkUpdates? setting a global setting so it can be
properly configured on any frontend. This patch does not include any
code to fix an existing improperly configured setting, which could cause
problems in the future, as the per-host option will override the global
one and will be uneditable without direct database modification.

Refs #12033

comment:3 Changed 6 years ago by Raymond Wagner <rwagner@…>

In eaafcb4a917c1b6055e5fb908a3bc6b747aba1c4/mythtv:

Make "DailyArtworkUpdates?" a global option

This makes the DailyArtworkUpdates? setting a global setting so it can be
properly configured on any frontend. This patch does not include any
code to fix an existing improperly configured setting, which could cause
problems in the future, as the per-host option will override the global
one and will be uneditable without direct database modification.

Refs #12033
(cherry picked from commit ffa364019e7d5bc0b88f4c83d21511090735b45d)

comment:4 Changed 6 years ago by mythtv@…

These two commits fix the hostname problem but they change the setting type from string to binary. Was that intended? I'm OK if it was but it made it look a bit weird in mysql when I was checking for the per-host setting.

comment:5 Changed 6 years ago by Raymond Wagner

Nope.

comment:6 Changed 6 years ago by Raymond Wagner <rwagner@…>

In e45e1ca7bf329e8ecea218f0e47cc080ad736b7e/mythtv:

Use proper string conversion for DailyArtworkUpdates? setting.

Refs #12033

comment:7 Changed 6 years ago by Raymond Wagner <rwagner@…>

In 1b7404d64080a69373f3b37fc174a5b62f9143ba/mythtv:

Use proper string conversion for DailyArtworkUpdates? setting.

Refs #12033
(cherry picked from commit e45e1ca7bf329e8ecea218f0e47cc080ad736b7e)

comment:8 Changed 6 years ago by skd5aner <skd5aner@…>

I can confirm, that for some reason, I had a hostname in this field and it was preventing any artwork from being retrieved. Once I nulled out that field, everything worked great the next time the housekeeper ran.

If possible, the fix should either account for a field that has a hostname there (and ignore it?) or perhaps even NULL out the field for the users as part of an update.

comment:9 Changed 4 years ago by Karl Egly

Component: MythTV - GeneralMythTV - Housekeeper
Milestone: unknown0.28
Owner: changed from Raymond Wagner to Karl Egly

I'll see if I can come up with a schema update to fix old values in time for fixes/0.28.

comment:10 in reply to:  9 Changed 4 years ago by Bill Meek

Milestone: 0.280.27
Resolution: Fixed
Status: acceptedclosed

Replying to dekarl:

I see 6 things to consider:

DailyArtworkUpdates plus:Action
No entry in settingsDo nothing
Single NULL hostDo nothing
Single (non NULL) hostConvert hostname to NULL, assume old data is desired
Single host and NULL hostDelete host setting
Multiple hostsGuess which frontend added the desired setting, convert 1, delete others
Multiple hosts and NULLDelete all non NULL entries

The final solution for this was: changeset:e45e1ca on Feb 3, 2014.

After 2 years, it's likely that users will have fixed their entry (or configured it properly after the above fixes.)

And any conversion and especially guesses may not have the desired result. I can compare the sum of the non NULL host's data with the number of non NULL hosts and if it were 0 or the the same as the non NULL host count, then INSERT the NULL version of the setting.

I recall significant discussion on the -users list. Mostly from those that didn't want artwork, so automatically turning it on based on earlier (mis)settings wouldn't be good. Even if I add a warning in the release notes.

I'm closing this as fixed, please reopen if you disagree.

Note: See TracTickets for help on using tickets.