Opened 6 years ago

Last modified 4 years ago

#12039 new Bug Report - General

mythfrontend locks up screen when adding web url

Reported by: air_drummer@… Owned by: JYA
Priority: minor Milestone: unknown
Component: Ports - OSX Version: 0.27-fixes
Severity: medium Keywords: web url lockup
Cc: Ticket locked: no

Description

trying to add a web url, unable to exit add screen. trying to switch to activity monitor to kill f/e, screen is locked. altho i am able to switch apps & kill f/e, the screen/dock are frozen: see attached

MythTV Version : v0.27-134-g5a5e1cd MythTV Branch : fixes/0.27 Network Protocol : 77 Library API : 0.27.20140103-1 QT Version : 4.8.5 Options compiled in:

profile darwin_da using_corevideo using_backend using_bindings_php using_darwin using_firewire using_frontend using_hdhomerun using_ceton using_libcrypto using_libdns_sd using_libudf using_mheg using_opengl using_opengl_video using_qtwebkit using_qtscript using_taglib using_profiletype using_appleremote using_bindings_php using_darwin_da using_mythtranscode using_opengl using_ffmpeg_threads using_mheg using_libudf

Attachments (1)

mythLockup.jpg (1.4 MB) - added by air_drummer@… 6 years ago.
mission control & dock magnify locked

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by air_drummer@…

Attachment: mythLockup.jpg added

mission control & dock magnify locked

comment:1 Changed 6 years ago by air_drummer@…

killing every user app (via ssh) still leaves screen locked, reboot needed

comment:2 Changed 6 years ago by Raymond Wagner

Trying to add a URL... to mythbrowser? All your image shows is a blurry photograph of your monitor, with an open terminal outputting logs from mythfilldatabase.

comment:3 Changed 6 years ago by air_drummer@…

is mythbrowser what comes up when clicking on web in mf/e? then that must b what locked up in add url...

the image was of the mess mf/e left of my display...couldn't have been 2 blurry if u could read the teenytiny terminal window;-)

comment:4 Changed 6 years ago by air_drummer@…

i should add that i could not exit from the web url listing after adding a url; it was at that point i tried to kill mfe using m.ctl, then the dock froze as shown in the image:-\

comment:5 Changed 6 years ago by stuartm

If the whole computer freezes then the problem is outside MythTV, it points to an operating system/kernel level bug.

MythTV may be triggering the bug, but that doesn't make it responsible. To use an analogy, if you lean against a wall and the wall falls down, was it your fault or was the wall badly built?

comment:6 Changed 6 years ago by air_drummer@…

sure, but not being able to exit from a myth subwindow is a myth problem

fix it

comment:7 Changed 6 years ago by Craig Treleaven <ctreleaven@…>

Some of the MythTV plugins are non-functional on OS X, at least the last time I played with them (~1 year ago). My experience was similar to that of the OP in that the screen became non-responsive to the keyboard or mouse. However, I was able to kill the frontend with from the command line or from Activity Monitor without hanging anything else. MythBrowser? and MythNews? would trigger the problem. MythGallery, MythWeather? and MythMusic worked OK. I saw a note from jya that seemed to confirm the problem. I follow the commits and haven't noticed any related fixes.

I opened a bug (11990) that I think could possibly be related as it is triggered by two pop-up dialogs in a row in the HDHomerun channel scanner. It seems to me that something about opening another window and then closing it and returning control to the former window is messed up on OS X. What the problem is--and why it affects OS X but not other platforms--is well beyond my skill set. And I could be completely out in left field! ;)

http://code.mythtv.org/trac/ticket/11990

BTW, air_drummer, If this is on the machine that you replaced the Core Duo with a Core2 Duo, that could be a contributing factor to the unrecoverable hang.

comment:8 Changed 6 years ago by air_drummer@…

a better analogy: ur steering wheel falls off & u crash into the poorly-built wall;-}

re: plugins...glad u left them out of the macports build, craig:-) and no, the hang was on my macbook pro.

comment:9 Changed 4 years ago by Karl Egly

Component: MythTV - GeneralPorts - OSX
Owner: set to JYA

The comments suggest that this may be an OSX specific issue, moving it there so it has a chance of being taken care of.

Note: See TracTickets for help on using tickets.