Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12068 closed Bug Report - General (Invalid)

Browse Mode Selected Channel EPG

Reported by: doa379@… Owned by:
Priority: major Milestone: 0.27.1
Component: MythTV - General Version: 0.27-fixes
Severity: medium Keywords: Browse Mode Broken Channel Update
Cc: Ticket locked: no

Description

mythTV 0.27.0+fixes20131218 (Debian)

Browse Mode appears broken due to several issues in Live-TV.

  1. Browse Mode will not update to current or newly selected channel. It continues to display EPG information from the original/first selected channel from source.

As a corollary, invoking the key press "I/i" gives wrong EPG information on the current channel.

  1. Browse Mode becomes unresponsive after 3-4 "Up/Down?" keypresses. Work-around is to quit Live-TV and re-enter.

Change History (5)

comment:1 Changed 6 years ago by stuartm

Status: newinfoneeded_new

Some, maybe all of this has already been fixed in 0.27. You're using a version from mid-December, can you try upgrading to the last 0.27-fixes?

comment:2 in reply to:  1 Changed 6 years ago by doa379@…

Replying to stuartm:

Some, maybe all of this has already been fixed in 0.27. You're using a version from mid-December, can you try upgrading to the last 0.27-fixes?

0.27-fixes supercedes 0.27 but the issue is still present. 0.27.0+fixes20131218 is the latest version provided by the Debian (Stable) distro, actually it's a Backport for Debian Stable.

To recreate this issue, try turning off Browser Mode in Mythfrontend settings, and then turn Browse Mode on again. The issue will reappear. So there's an issue with Browse Mode which still needs fixing.

I don't believe these issues (1., 2.) were present in 0.26. So something has changed recently as of mythTV 0.27.

These issues are fairly important because they degrade considerably the usage experience of mythTV.

  1. Browse Mode needs to update it's screen to the currently selected channel.
  2. Browse Mode becomes non-responsive after browsing a certain number of channels.

comment:3 Changed 6 years ago by stuartm

Resolution: Invalid
Status: infoneeded_newclosed

You should take this up with the Debian packagers, we've already fixed these issues and they just aren't supplying up to date packages.

comment:4 Changed 6 years ago by stuartm

Specifically it was fixed in [8307dd49]

Last edited 6 years ago by stuartm (previous) (diff)

comment:5 Changed 6 years ago by doa379@…

OK I will follow this up in this fix.

Note: See TracTickets for help on using tickets.