Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12122 closed Bug Report - General (Won't Fix)

OSD & Menus do not update if program audio changes between 2.0 to 5.1 mid-transmission

Reported by: JohnBergqvist Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I've noticed that if a station changes it's audio track from stereo to 5.1 and vice versa mid-playback - for example, when a 5.1 program starts - (which is something the HD channels using DVB-S2 in the UK do), the OSD & Audio track pop-up menu does not update to reflect this. Unfortunately I am unable to test whether the change also occurs with the actual audio, as I do not have a 5.1 speaker system.

What I can confirm is that the change is picked up within 3rd party clients such as XBMC, which leads me to believe that the problem is only on the User Interface (although within MythTV, that may also restrict what audio channels are played through the speakers, I'm not sure)

Essentially, the OSD and User Interface (and possibly what audio comes out of the speakers too, although I am unable to test this) only sticks to what the audio format is at the moment the file playback is started, and doesn't change when the audio itself does, mid-program. This may prove an issue when setting the audio format flag for the recorded file however (as at the very start of the recording, the 5.1 program itself may not have begun, and so the audio may be still set to stereo.

5.1,stereo,surround,swtich,audio

Change History (4)

comment:1 Changed 5 years ago by JYA

Resolution: Won't Fix
Status: newclosed

comment:2 Changed 5 years ago by JYA

The audio isn't changed because the output only supports stereo. We've been over this already.

Want to see audio changing, use a multi-channel audio setup

comment:3 in reply to:  2 Changed 5 years ago by paulh

Replying to jyavenard:

The audio isn't changed because the output only supports stereo. We've been over this already.

Want to see audio changing, use a multi-channel audio setup

This seems backward to me. Most players report the audio format contained in the playing file not what the output supports.

comment:4 Changed 5 years ago by JYA

It's in reply to "and possibly what audio comes out of the speakers too, although I am unable to test this) only sticks to what the audio format is at the moment the file playback is started, and doesn't change when the audio itself does, mid-program." Which is an assumption on how the system behaves without even verifying that it's indeed the case.

There's no issue with output and audio detection. It just happens that as the output only supports stereo, and the audio is ac3 and the codec supports down mixing, ffmpeg is configured to a maximum number of channels of 2. This disable later detection of channel number change.

OTher audio codecs behaves differently.

Note: See TracTickets for help on using tickets.