Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12219 closed Bug Report - Crash (fixed)

mythbackend segfault - EITCache::WriteChannelToDB

Reported by: Andreas Sundstrom <sunkan@…> Owned by: Karl Egly
Priority: minor Milestone: 0.27.4
Component: MythTV - EIT Version: 0.27-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

My mythbackend segfaults from time to time. I have now got a core file and will attach the gdb output from that.

Need help to find out the root cause, can test patches if needed.

Version: v0.27.3-106-g302dde1 git commit 302dde18b440a52f8c53744129a4c9adfee3ef71

Attachments (2)

gdb.txt (41.3 KB) - added by Andreas Sundstrom <sunkan@…> 5 years ago.
GDB - thread apply all bt full - output
0001-Attempt-to-fix-segfault-in-EITCache-assumed-to-be-du.patch (1.0 KB) - added by Karl Egly 5 years ago.
Potential fix for testing

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by Andreas Sundstrom <sunkan@…>

Attachment: gdb.txt added

GDB - thread apply all bt full - output

Changed 5 years ago by Karl Egly

Potential fix for testing

comment:1 Changed 5 years ago by Andreas Sundstrom <sunkan@…>

Patch applied, will wait and see how it goes. My gut feeling says that I have had a crash approximately once a day previously.

comment:2 Changed 5 years ago by Karl Egly

Status: newinfoneeded_new

comment:3 Changed 5 years ago by Karl Dietz <dekarl@…>

In 477c3f2b1cd3bcb38c5cfd9a3a934a95e1a13beb/mythtv:

Attempt to fix segfault in EITCache assumed to be due to QMap race

Refs #12219

comment:4 Changed 5 years ago by Andreas Sundstrom <sunkan@…>

Server has been up and running for 6 days now, I'd say this solved my problem.

comment:5 Changed 5 years ago by Karl Dietz <dekarl@…>

Resolution: fixed
Status: infoneeded_newclosed

In 5c76f3356fe2178677019e0415151e64605411c4/mythtv:

Attempt to fix segfault in EITCache assumed to be due to QMap race

Fixes #12219
(cherry picked from commit 477c3f2b1cd3bcb38c5cfd9a3a934a95e1a13beb)

comment:6 Changed 5 years ago by Karl Egly

Milestone: unknown0.27.4
Version: Unspecified0.27-fixes

Thank you for testing and reporting back.

Note: See TracTickets for help on using tickets.