Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1224 closed defect (fixed)

svn 8873: Channel changes broke.

Reported by: jasonmollman@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This broke in 8867, but I saw that Isaac applied a fix in 8868 so I thought I'd try it. It seems that the last digit of any 3 digit channel change is not being completed. For example, changing to channel 400 only goes to 40, channel 123 goes to channel 12, etc. gdb trace is attached.

Attachments (4)

gdb.txt (12.8 KB) - added by jasonmollman@… 14 years ago.
mythbackend.log.channel (5.7 KB) - added by jasonmollman@… 14 years ago.
mythfrontend.log (5.9 KB) - added by jasonmollman@… 14 years ago.
temp.log (5.2 KB) - added by anonymous 14 years ago.

Download all attachments as: .zip

Change History (15)

Changed 14 years ago by jasonmollman@…

Attachment: gdb.txt added

comment:1 Changed 14 years ago by jasonmollman@…

This appears to occur if you enter the channel numbers through the remote. Selecting the channel from the program guide works correctly.

comment:2 Changed 14 years ago by Isaac Richards

Resolution: invalid
Status: newclosed

Need frontend and backend logs. Also, there's absolutely no way that [8867] broke this, so, it would be helpful to know the actual revision number that broke things.

comment:3 Changed 14 years ago by danielk

In addition to the logs (at "mythbackend -v record", and "mythfrontend -v playback"), is smart channel changing enabled or disabled?

comment:4 Changed 14 years ago by Isaac Richards

Can't reproduce this, either. Renumbered a bunch of channels to have 3-digit numbers where the first two digits were also valid other channels. Stuff worked fine.

comment:5 Changed 14 years ago by jasonmollman@…

Resolution: invalid
Status: closedreopened

It broke somewhere between 8862 and 8867. Attaching frontend and backend logs.

Changed 14 years ago by jasonmollman@…

Attachment: mythbackend.log.channel added

comment:6 Changed 14 years ago by Isaac Richards

Resolution: invalid
Status: reopenedclosed

Your backend log shows it switching between 400 and 40 just fine.

Changed 14 years ago by jasonmollman@…

Attachment: mythfrontend.log added

comment:7 Changed 14 years ago by jasonmollman@…

Resolution: invalid
Status: closedreopened

In the frontend log, channel 400 was entered on the remote at 17:32:16. It went to channel 40.

comment:8 Changed 14 years ago by Isaac Richards

So, at 17:32:16, you entered 400, when you were already on 400?

comment:9 Changed 14 years ago by jasonmollman@…

Yes, I did. Here is another frontend snippet with a channel change from 57 to 400 (pressing 400). It goes to 40. For a split second a "?" appears after the press of the last digit.

Changed 14 years ago by anonymous

Attachment: temp.log added

comment:10 Changed 14 years ago by Isaac Richards

Resolution: fixed
Status: reopenedclosed

(In [8875]) Fix bug in smart channel change stuff that would disallow channels that were a multiple of 100. I assume this fixes #1224, as that's the only way I could reproduce the bug.

comment:11 Changed 14 years ago by jasonmollman@…

Confirmed fixed. Tested in 8880.

Note: See TracTickets for help on using tickets.