Opened 5 years ago

Closed 5 years ago

#12292 closed Bug Report - General (Invalid)

mythfrontend assumes that the mysql database and possibly the backend are local.

Reported by: cerise-mythtv@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.27.3
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi there, I'm using mythtv-0.27.3 (dated 20140907) on Gentoo.

I have an unusual setup in that I have a server in one room which runs the backend and saves all the files into a directory which is shared via NFS.

On my laptop, I used to be able to run mythfrontend on my laptop and it would connect to the database on the server and use the (identical) pathnames through NFS to access the files.

Since upgrading to 0.27.3 (from some other version -- I don't recall which), mythfrontend forces me into mythtv-setup because it can't connect to ports on localhost.

I have put in the IP address for the server on the backend in mythtv-setup and it's still trying to connect to localhost. I just did a full examination of the mythtv databases and there is nowhere that an IP or hostname is used which does not correspond to the appropriate DNS name or the IP address of the server.

I've set up some iptables rules to forward from my laptop to the server. I can tell that these rules work because I can connect to the mysql database on the server through mysql's command line tool.. There is no mysql database running on the laptop. Moreover, by running iptables -t nat -L -v, I can see the packet & bytes counters increment when I run the mysql command line tool.

I've noticed that if I use mythfrontend, then those packets don't go up at all.

That indicates to me that mythfrontend is always trying to connect to the database by way of the local UNIX socket rather than the settings which I've put into mythtv-setup.

Attachments (1)

mythtv.log (69.2 KB) - added by cerise-mythtv@… 5 years ago.
Output from mythfrontend as well as iptables output showing no net traffic.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by cerise-mythtv@…

Attachment: mythtv.log added

Output from mythfrontend as well as iptables output showing no net traffic.

comment:1 Changed 5 years ago by stuartm

Resolution: Invalid
Status: newclosed

"QSqlDatabase: QMYSQL driver not loaded"

That's your problem. It's not a bug but a broken/missing lib for QT.

Note: See TracTickets for help on using tickets.