Opened 5 years ago

Closed 5 years ago

#12301 closed Bug Report - General (Duplicate)

mythfilldatabase should warn if it can't write to /tmp/mythtv_ddp_data

Reported by: mythtv@… Owned by: stuartm
Priority: minor Milestone: unknown
Component: MythTV - Mythfilldatabase Version: 0.27-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If for some reason you have a /tmp/mythtv_ddp_data file laying around that is owned by some other user (or otherwise can't be written to) then mythfilldatabase simply uses the data in that file when running from the backend, and thus not actually doing what it's supposed to be doing.

Attachments (1)

diff (628 bytes) - added by mythtv@… 5 years ago.
Patch to check if opening file succeeded, and warn if it didn't.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by mythtv@…

Attachment: diff added

Patch to check if opening file succeeded, and warn if it didn't.

comment:1 Changed 5 years ago by stuartm

Resolution: Duplicate
Status: newclosed

Duplicate of #12253 which is fixed in master but not yet? backported to 0.27

Note: See TracTickets for help on using tickets.