Opened 4 years ago

Last modified 3 years ago

#12347 new Bug Report - General

Virtual keyboard is not showing

Reported by: Frank Phillips <fphillips81@…> Owned by: stuartm
Priority: minor Milestone: unknown
Component: MythTV - User Interface Library Version: 0.27.4
Severity: medium Keywords:
Cc: Stuart Auchterlonie Ticket locked: no

Description

As also reported on the list, when pressing SELECT with an editable line focused, the virtual keyboard doesn't popup. It seems as though the arrows are captured, because you can't move focus until hitting escape. I'm using the General setup page in the frontend, but also confirmed it in the General mythtv-setup page. It has worked in the past on fixes/0.27.

http://lists.mythtv.org/pipermail/mythtv-users/2015-January/375470.html

Change History (5)

comment:1 Changed 4 years ago by Frank Phillips <fphillips81@…>

I bisected this to:

[39686c6] Fix old Qt setting screens preventing them from accepting keyboard inputs

comment:2 Changed 4 years ago by Stuart Auchterlonie

Cc: Stuart Auchterlonie added

Frank, was [39686c6] the commit which broke it, or the one that's needed to fix it?

comment:3 Changed 4 years ago by Frank Phillips <fphillips81@…>

It's the offending commit - the commit preceding it was the last good one. I let the word "to" be ambiguous, oops.

I should note I'm on Qt-4.8.6/Archlinux. Karl Newman in the linked thread confirmed that reverting that commit fixed it for him, too.

comment:4 Changed 4 years ago by Frank Phillips <fphillips81@…>

Ok, I have noticed that it is the _old_ Qt virtual keyboard in the _old_ Qt setting screens that is broken. The MythUI keyboard in MythUI screens still works. For instance:

Works:
Recording Rules > Metadata Options
Setup > Media Settings > Player Settings

Doesn't work:
Setup > General
Setup > Video > Playback Profiles (Custom filters)
mythtv-setup > General

In 39686c6 the comment is that widget children are disabled on OSX. Maybe this just needs an #ifdef?

comment:5 Changed 3 years ago by Frank Phillips <fphillips81@…>

Only tested on Linux, should be tested on OSX to be sure.

https://github.com/fphillips/mythtv/commit/3a4d946901cc36af5f3354fa9fb3e6c1dd044f48

Note: See TracTickets for help on using tickets.