Opened 5 years ago

Closed 3 years ago

Last modified 21 months ago

#12456 closed Bug Report - General (fixed)

Always display closed captioning or subtitles broken.

Reported by: eliteforce82nd@… Owned by: Peter Bennett
Priority: minor Milestone: 0.28.1
Component: MythTV - General Version: 0.27.4
Severity: medium Keywords: Closed Captions Subtitles
Cc: pbennett@… Ticket locked: no

Description

Since 27.3, the option for "Always display closed captioning or subtitles" has stopped working or no longer obeys the option. Manually turning it on with key bind "T" works and displays captions normally. But on channel change or between recordings it turns off. You can turn it back on again using "T" but will turn off if you do either or exit to menu.

No errors reported in mythfrontend.

Last version it was working properly: 27.2

mythfrontend --version
Please attach all output as a file in bug reports.
MythTV Version : v0.27.4-69-gb7afc9b
MythTV Branch : fixes/0.27
Network Protocol : 77
Library API : 0.27.20141016-1
QT Version : 4.8.6
Options compiled in:
 linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_frontend using_hdhomerun using_ceton using_hdpvr using_ivtv using_joystick_menu using_lirc using_mheg using_opengl using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_taglib using_v4l2 using_x11 using_xrandr using_xv using_profiletype using_mythlogserver using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_mheg using_libass

Change History (16)

comment:1 Changed 5 years ago by stuartm

Milestone: unknown0.27.5
Owner: set to Jim Stichnoth
Status: newassigned

comment:2 Changed 5 years ago by Stuart Auchterlonie

Milestone: 0.27.50.27.6

comment:3 Changed 4 years ago by eliteforce82nd@…

Just an update, I wiped one of my frontends in the last 48 hours after having issues with ubuntu 14.04 and loaded archlinux. I noticed that the "Always display closed captioning" option is obeyed on both open-source drivers (nouveau and xf86-video-ati aka:radeon) with both opengl and vdpau profiles.

But if I install proprietary drivers I get differing results.

AMD drivers v15.7 for hd 6310 and v12.9 for hd 4650 using opengl profiles, the option is obeyed and captions displays automatically and remain consistent. But if you use vdpau profiles, the option is not longer obeyed, and you have to manually turn on captions after entering live-tv or recordings.

(note, downgrading Xorg to 1.12 for driver v12.9, it was upgraded back to latest version of 1.17 for the nvidia swap)

Swapping out video cards and going to Nvidia Geforce GT 210 and installing 340.xx drivers from arch or ubuntu 331.xx; Using either opengl and vdpau profiles the option is not obeyed, and you have to manually turn on captions after entering live-tv or recordings.

Since I have performance problems with Open-source drivers I need to use proprietary drivers for a smooth playback.

I've also updated my foxconn nT-330i nano-pc which uses an atom 1.86ghz processor, nvidia ion chip and using nvidia proprietary drivers on xubuntu 12.04 kernel 3.2.0, this frontend has reproduced the problem as well.

Hope this helps.

comment:4 Changed 4 years ago by ismot@…

I have this problem. When starting livetv, there is allways subs, but after few channel changes they are gone. Must to enable them again. I am using vdpau.

comment:5 Changed 4 years ago by Karl Egly

Milestone: 0.27.60.27.7

Reschedule all tickets planned for, but not solved in time for, 0.27.6 to 0.27.7.

comment:6 Changed 3 years ago by Peter Bennett

Cc: pbennett@… added

comment:7 Changed 3 years ago by eliteforce82nd@…

comment:8 Changed 3 years ago by eliteforce82nd@…

Seems like stichnot messed with it last.

https://github.com/MythTV/mythtv/commit/bcf888fdd4034997c2f2a5d0d877da0e1f463c2e

https://github.com/MythTV/mythtv/commit/ac3a988f2e9140322b1a15c34d6ac87071c69d7e

Some more clues, there are other subtitles fixes in 0.27 but I don't think they are the problem.

Then this one on 0.28rc1, doesn't seem like it complete, not sure if related https://github.com/MythTV/mythtv/commit/0bd79053bc7476bab4d7e71a86b37dc6b27ad05f

comment:9 Changed 3 years ago by Peter Bennett

Jim

Do you have any objections to me taking this ticket and fixing it for the OP?

Peter

comment:10 in reply to:  9 Changed 3 years ago by Jim Stichnoth

Replying to pbennett:

Jim

Do you have any objections to me taking this ticket and fixing it for the OP?

Definitely no objections, and thanks!

IIRC, the problem (or at least one problem) is that the "always display captions" setting is only checked when playback starts, and if captions don't appear "soon enough" after playback starts, or "disappear" and then reappear during playback, that setting isn't considered. The caption availability is tracked in the decoder thread, then communicated via some (synchronized?) fields to the UI thread, making it extra tricky to manage. (assuming I'm remembering correctly)

comment:11 Changed 3 years ago by Peter Bennett

Owner: changed from Jim Stichnoth to Peter Bennett
Status: assignedaccepted

comment:12 Changed 3 years ago by Peter Bennett

The field textDesired indicates that subtitles should be activated, but when the mythplayer discovers no subtitles (because they have not yet been detected) it turns that flag off. Change to turn the flag off only if the operator requested to turn off subtitles or captions. Detect that the operator requested it by using the osd_msg flag, i.e. the operator is being notified that they are turned off.

Here is the fix in my repository:

https://github.com/bennettpeter/mythtv/commit/2225fdf44944b3f860d1252dbaf60c5d43fdd55f

I will commit it to MythTV in a couple of days.

comment:13 Changed 3 years ago by Peter Bennett

Milestone: 0.27.70.28.1

comment:14 Changed 3 years ago by Peter Bennett <pbennett@…>

Resolution: fixed
Status: acceptedclosed

In 346011cfcd21e5cdb88bdcd775a344c804160520/mythtv:

Fix "always display subtitles" not activating subtitles in certain cases.

Fixes #12456

comment:15 Changed 3 years ago by Peter Bennett <pbennett@…>

In da908d5316415651de71fd1c007ba0098c41e188/mythtv:

Fix "always display subtitles" not activating subtitles in certain cases.

Fixes #12456

(cherry picked from commit 346011cfcd21e5cdb88bdcd775a344c804160520)

comment:16 Changed 21 months ago by Peter Bennett

Owner: changed from Peter Bennett to Peter Bennett
Note: See TracTickets for help on using tickets.