Opened 4 years ago

Closed 4 years ago

#12496 closed Bug Report - Crash (Fixed)

Daily tmdb3.py exception

Reported by: jfbauer@… Owned by: Karl Egly
Priority: minor Milestone: 0.27.6
Component: MythTV - Mythmetadatalookup Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Most every day I get a popup about an error in some program. It is /usr/share/mythtv/metadata/Movie/tmdb3.py. (The popup is a bit of a pain to deal with on a TV BTW. And I am getting realy tired of it.)

Looking at the logs I found this triggers the error:

/usr/share/mythtv/metadata/Movie/tmdb3.py -l en -a US -C 2731

Traceback (most recent call last):

File "/usr/share/mythtv/metadata/Movie/tmdb3.py", line 300, in <module>

main()

File "/usr/share/mythtv/metadata/Movie/tmdb3.py", line 297, in main

buildCollection(args[0], opts)

File "/usr/share/mythtv/metadata/Movie/tmdb3.py", line 179, in buildCollection

m.title = collection.name

File "/usr/lib/python2.7/dist-packages/MythTV/tmdb3/util.py", line 153, in get

self.poller.get(inst, owner)()

File "/usr/lib/python2.7/dist-packages/MythTV/tmdb3/util.py", line 70, in call

if not self.apply(req.readJSON(), False):

File "/usr/lib/python2.7/dist-packages/MythTV/tmdb3/cache.py", line 118, in call

data = self.func(*args, kwargs)

File "/usr/lib/python2.7/dist-packages/MythTV/tmdb3/request.py", line 129, in readJSON

handle_status(data, url)

File "/usr/lib/python2.7/dist-packages/MythTV/tmdb3/request.py", line 164, in handle_status

status = status_handlers[data.get('status_code', 1)]

KeyError?: 34

I added a print in after 'url = self.get_full_url()' and the URL was 'http://api.themoviedb.org/3/collection/2731?api_key=c27cb71cff5bd76e1a7a009380562c62&language=en' Fetching that, you get a 404 Not Found error.

System mythbuntu (Ubuntu 12.04.5 LTS) mythtv version 2:0.27.5+fixes.20150803.e2a11c9-0ubuntu0mythbuntu4

Looks similar but not identical to bug #12455

Change History (5)

comment:1 Changed 4 years ago by Karl Egly

Milestone: unknown0.27.6
Owner: changed from JYA to Karl Egly
Status: newassigned

The cause appears to be that 2731 is a movie, but the request is for a movie collection. Retrieving this id as a movie returns "Indochine"

/usr/share/mythtv/metadata/Movie/tmdb3.py -l en -a US -D 2731

The fix would be to catch the exception and return a proper error for "collection # not found".

comment:2 Changed 4 years ago by Karl Dietz <dekarl@…>

In 7ffccb599649d6c5e03530e759bca339c32b4e49/mythtv:

hack to return an empty result set for unknown inetrefs

Refs #12496

comment:3 Changed 4 years ago by Karl Egly

Status: assignedinfoneeded

Candidate for fixes/0.27 after some burning in.

comment:4 Changed 4 years ago by Karl Dietz <dekarl@…>

In 3ea54d78f8993a09037823251d7daf9e3b0e2686/mythtv:

hack to return an empty result set for unknown inetrefs

Refs #12496

(cherry picked from commit 7ffccb599649d6c5e03530e759bca339c32b4e49)

comment:5 Changed 4 years ago by Karl Egly

Resolution: Fixed
Status: infoneededclosed

The popup should be gone with this fix. If you can find out why the lookup is done in the first place we can improve that, too. Please open a new ticket in that case.

Note: See TracTickets for help on using tickets.