Opened 4 years ago

Closed 4 years ago

#12539 closed Bug Report - Crash (Duplicate)

tmdb3.py consistently fails with country specific option

Reported by: laughing_man77@… Owned by: Karl Egly
Priority: major Milestone: unknown
Component: MythTV - Mythmetadatalookup Version: Unspecified
Severity: medium Keywords: tmdb3.py country AU
Cc: Ticket locked: no

Description

fetching of metadata from TMDB consistently fails on my system. TV series still works fine. Going through the crash reports, I narrowed it down to:

$ /usr/share/mythtv/metadata/Movie/tmdb3.py -l en -a AU -d 6535
Usage: tmdb3.py [options]

tmdb3.py: error: no such option: -d
javery@server:~$ /usr/share/mythtv/metadata/Movie/tmdb3.py -l en -a AU -D 6535
Traceback (most recent call last):                                                                                                                                                                               
  File "/usr/share/mythtv/metadata/Movie/tmdb3.py", line 312, in <module>                                                                                                                                        
    main()
  File "/usr/share/mythtv/metadata/Movie/tmdb3.py", line 306, in main
    buildSingle(args[0], opts)
  File "/usr/share/mythtv/metadata/Movie/tmdb3.py", line 70, in buildSingle
    index = zip(*releases)[0].index(opts.country)
ValueError: tuple.index(x): x not in tuple

After Checking out https://code.mythtv.org/trac/ticket/12538 (Not sure if this ticket is a duplicate of #12538), I tried:

$ /usr/share/mythtv/metadata/Movie/tmdb3.py -l en -a US -D 6535

...and this did not fail.

Change History (3)

comment:1 Changed 4 years ago by laughing man <laughing_man77@…>

Sorry I pasted in too many lines - it should read only:

$ /usr/share/mythtv/metadata/Movie/tmdb3.py -l en -a AU -D 6535
Traceback (most recent call last):
  File "/usr/share/mythtv/metadata/Movie/tmdb3.py", line 312, in <module>
    main()
  File "/usr/share/mythtv/metadata/Movie/tmdb3.py", line 306, in main
    buildSingle(args[0], opts)
  File "/usr/share/mythtv/metadata/Movie/tmdb3.py", line 70, in buildSingle
    index = zip(*releases)[0].index(opts.country)
ValueError: tuple.index(x): x not in tuple

comment:2 Changed 4 years ago by Karl Egly

Owner: changed from JYA to Karl Egly
Status: newassigned

closing as duplicate of #12538

comment:3 Changed 4 years ago by Karl Egly

Resolution: Duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.