Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12626 closed Bug Report - General (fixed)

UK EPG fix-up confused by "NEW: Marvel's Agents of S.H.I.E.L.D."

Reported by: Joe Bryant <tenminjoe@…> Owned by: Karl Egly
Priority: minor Milestone: 29.0
Component: MythTV - EIT Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The (otherwise very useful!) fix to remove "NEW:" from program titles seems to get confused by "NEW: Marvel's Agents of S.H.I.E.L.D."

The title is transformed to "Marvel's Agents of S" instead of "Marvel's Agents of S.H.I.E.L.D."

When the title in the EIT doesn't have the "NEW" prefix, it shows up correctly as "Marvel's Agents of S.H.I.E.L.D."

Change History (9)

comment:1 Changed 4 years ago by Karl Dietz <dekarl@…>

In 7cf07dc382fbdc479a6757323530c0443d229ecb/mythtv:

test UK "New" Fixup with "Marvel's Agents of S.H.I.E.L.D."

Refs #12626

comment:2 Changed 4 years ago by Karl Egly

Status: newinfoneeded_new

I could not reproduce the issue in master. What version are you running?

comment:3 Changed 4 years ago by mythtvbugs@…

I see this with v0.27.6-14-gd8dc0e7 on the Master, and v0.27.5-73-g6883c20 for ARM on the slave (which has the DVB-T USB dongle fitted).

comment:4 Changed 4 years ago by Joe Bryant <jb@…>

I should clarify that there's a little bit of deduction/guesswork here - I don't actually know 100% what the incoming data looks like.

I definitely see the "Marvel's Agents of S" final result, and it only happens on the first showing of each episode, but I don't know exactly what data is going into the process - it's possible that E4 are sending some new kind of nonsense data in the first place.

comment:5 Changed 4 years ago by mythtvbugs@…

All of my recordings of that show are titled "Marvel's Agents of S" with the subtitle "H.I.E.L.D <actual subtitle here>".

comment:6 Changed 4 years ago by Gary Buhrmaster <gary.buhrmaster@…>

I believe the fix is in master (and not in any fixes/0.27 branch). Test there. Or backport to your local copy of 0.27 and compile.

comment:7 Changed 4 years ago by Karl Dietz <dekarl@…>

Resolution: fixed
Status: infoneeded_newclosed

In 62f9970abf73342ceb88365dcc5e9b7f1930f5ee/mythtv:

ugly fix for UK EIT Fixups to handle 'Agents of Shield'

A better regex like (?:[:]|(?<=[\!\?])|(?<!\.\w)\.|(?<=\.\w\.))\s
is not supported due to missing support for lookbehind.
(Keep the full stop if its part of an abbreviation)

Fixes #12626

comment:8 Changed 4 years ago by Karl Egly

Milestone: unknown0.29

comment:9 Changed 4 years ago by Stuart Auchterlonie

Milestone: 0.2929.0

Milestone renamed

Note: See TracTickets for help on using tickets.