Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12633 closed Bug Report - General (fixed)

EIT fixup for Law & Order: Special Victims Unit needed (Freesat UK)

Reported by: daniel@… Owned by: Karl Egly
Priority: minor Milestone: 0.27.7
Component: MythTV - EIT Version: 0.27.5
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Some showings of SVU have the correct title "Law & Order: Special Victims Unit" and some have the title "Law & Order" and the subtitle "Special Victims Unit". As it's inconsistent, I suspect the problem is outside MythTV but hopefully it can be fixed in a fixup. Here are the upcoming showings from my program table:

mysql> SELECT title, subtitle, starttime FROM program WHERE starttime>NOW() AND title LIKE 'Law & Order%' AND (title LIKE '%Special Victims Unit' OR subtitle LIKE 'Special Victims Unit');
+-----------------------------------+----------------------+---------------------+
| title                             | subtitle             | starttime           |
+-----------------------------------+----------------------+---------------------+
| Law & Order                       | Special Victims Unit | 2016-02-05 23:00:00 |
| Law & Order                       | Special Victims Unit | 2016-02-06 00:00:00 |
| Law & Order                       | Special Victims Unit | 2016-02-09 21:00:00 |
| Law & Order                       | Special Victims Unit | 2016-02-09 22:00:00 |
| Law & Order: Special Victims Unit | Sugar                | 2016-02-06 23:25:00 |
| Law & Order: Special Victims Unit | Sugar                | 2016-02-07 00:25:00 |
| Law & Order: Special Victims Unit | Sugar                | 2016-02-07 23:25:00 |
| Law & Order: Special Victims Unit | Unstable             | 2016-02-06 22:30:00 |
| Law & Order: Special Victims Unit | Unstable             | 2016-02-06 23:30:00 |
| Law & Order: Special Victims Unit | Unstable             | 2016-02-07 22:30:00 |
| Law & Order: Special Victims Unit | Wet                  | 2016-02-04 22:00:00 |
| Law & Order: Special Victims Unit | Wet                  | 2016-02-04 23:00:00 |
| Law & Order: Special Victims Unit | Wet                  | 2016-02-09 22:00:00 |
| Law & Order: Special Victims Unit | Wet                  | 2016-02-09 23:00:00 |
+-----------------------------------+----------------------+---------------------+

Change History (9)

comment:1 Changed 3 years ago by daniel@…

At dekarl's request, here are a couple of samples from dvbsnoop. First, from an event where the title is being split:

------------------------------------------------------------
SECT-Packet: 00002869   PID: 18 (0x0012), Length: 1136 (0x0470)
Time received: Wed 2016-02-03  15:44:21.875
------------------------------------------------------------
  0000:  51 f4 6d 32 c0 cf b8 f8  30 06 23 3a b8 51 06 cd   Q.m2....0.#:.Q..
  0010:  e0 53 21 00 00 01 00 00  00 ff 50 06 f1 03 01 75   .S!.......P....u
  0020:  6e 64 50 06 f2 03 02 65  6e 67 4d b3 65 6e 67 21   ndP....engM.eng!
  0030:  4c 61 77 20 26 20 4f 72  64 65 72 3a 20 53 70 65   Law & Order: Spe
  0040:  63 69 61 6c 20 56 69 63  74 69 6d 73 20 55 6e 69   cial Victims Uni
  0050:  74 8d 43 72 69 6d 65 20  64 72 61 6d 61 20 73 65   t.Crime drama se
  0060:  72 69 65 73 2e 20 44 65  74 65 63 74 69 76 65 20   ries. Detective 
  0070:  43 61 73 73 69 64 79 20  69 73 20 61 63 63 75 73   Cassidy is accus
  0080:  65 64 20 6f 66 20 72 61  70 69 6e 67 20 61 20 77   ed of raping a w
  0090:  6f 6d 61 6e 20 77 68 69  6c 65 20 68 65 20 77 61   oman while he wa
  00a0:  73 20 77 6f 72 6b 69 6e  67 20 75 6e 64 65 72 63   s working underc
  00b0:  6f 76 65 72 20 61 73 20  74 68 65 20 74 72 69 61   over as the tria
  00c0:  6c 20 6f 66 20 61 20 70  69 6d 70 20 62 65 67 69   l of a pimp begi
  00d0:  6e 73 2e 20 28 53 31 34  20 45 70 20 31 37 29 5f   ns. (S14 Ep 17)_
  00e0:  04 00 00 23 3a 54 02 f0  00 76 08 c4 06 2f 56 37   ...#:T...v.../V7
  00f0:  50 36 34 76 08 c8 06 2f  52 37 43 5a 43 89 1a 01   P64v.../R7CZC...
  0100:  01 65 6e 67 43 6f 6e 74  61 69 6e 73 20 41 64 75   .engContains Adu
  0110:  6c 74 20 74 68 65 6d 65  73 06 ce e0 53 22 00 00   lt themes...S"..
  0120:  01 00 00 01 2e 50 06 f1  03 01 75 6e 64 50 06 f2   .....P....undP..
  0130:  03 02 65 6e 67 50 06 f3  10 05 65 6e 67 50 06 f2   ..engP....engP..
  0140:  40 06 65 6e 67 4d ee 65  6e 67 21 4c 61 77 20 26   @.engM.eng!Law &
  0150:  20 4f 72 64 65 72 3a 20  53 70 65 63 69 61 6c 20    Order: Special 
  0160:  56 69 63 74 69 6d 73 20  55 6e 69 74 c8 57 65 74   Victims Unit.Wet
  0170:  3a 20 50 6f 6c 69 63 65  20 64 72 61 6d 61 20 73   : Police drama s
  0180:  65 72 69 65 73 20 61 62  6f 75 74 20 61 20 73 65   eries about a se
  0190:  78 20 63 72 69 6d 65 20  75 6e 69 74 20 62 61 73   x crime unit bas
  01a0:  65 64 20 69 6e 20 4e 65  77 20 59 6f 72 6b 2e 20   ed in New York. 
  01b0:  41 20 63 6f 6c 6c 65 67  65 20 70 72 6f 66 65 73   A college profes
  01c0:  73 6f 72 20 69 73 20 70  72 69 6d 65 20 73 75 73   sor is prime sus
  01d0:  70 65 63 74 20 77 68 65  6e 20 61 20 77 6f 6d 61   pect when a woma
  01e0:  6e 20 69 73 20 66 6f 75  6e 64 20 64 65 61 64 20   n is found dead 
  01f0:  61 6e 64 20 74 65 73 74  73 20 72 65 76 65 61 6c   and tests reveal
  0200:  20 73 68 65 20 77 61 73  20 70 6f 69 73 6f 6e 65    she was poisone
  0210:  64 20 62 79 20 72 61 72  65 20 6d 75 73 68 72 6f   d by rare mushro
  0220:  6f 6d 73 2e 20 28 53 31  32 20 45 70 20 35 29 5b   oms. (S12 Ep 5)[
  0230:  41 44 2c 53 5d 5f 04 00  00 23 3a 54 02 f0 00 76   AD,S]_...#:T...v
  0240:  08 c4 06 2f 56 36 4a 37  41 76 08 c8 06 2f 52 37   .../V6J7Av.../R7
  0250:  43 31 53 06 cf e0 53 23  00 00 00 55 00 01 03 50   C1S...S#...U...P
  0260:  06 f1 03 01 75 6e 64 50  06 f2 03 02 65 6e 67 4d   ....undP....engM
  0270:  b7 65 6e 67 0b 4c 61 77  20 26 20 4f 72 64 65 72   .eng.Law & Order
  0280:  a7 43 72 69 6d 65 20 64  72 61 6d 61 20 73 65 72   .Crime drama ser
  0290:  69 65 73 2e 20 54 68 65  20 70 72 6f 73 65 63 75   ies. The prosecu
  02a0:  74 69 6f 6e 20 6f 66 20  61 20 70 72 6f 2d 6c 69   tion of a pro-li
  02b0:  66 65 20 61 63 74 69 76  69 73 74 20 66 6f 72 20   fe activist for 
  02c0:  74 68 65 20 6d 75 72 64  65 72 20 6f 66 20 61 20   the murder of a 
  02d0:  6c 61 74 65 2d 74 65 72  6d 20 61 62 6f 72 74 69   late-term aborti
  02e0:  6f 6e 69 73 74 20 74 68  72 65 61 74 65 6e 73 20   onist threatens 
  02f0:  74 6f 20 64 72 69 76 65  20 61 20 77 65 64 67 65   to drive a wedge
  0300:  20 62 65 74 77 65 65 6e  20 43 75 74 74 65 72 20    between Cutter 
  0310:  61 6e 64 20 52 75 62 69  72 6f 73 61 2e 20 28 53   and Rubirosa. (S
  0320:  32 30 20 45 70 20 35 29  5f 04 00 00 23 3a 54 02   20 Ep 5)_...#:T.
  0330:  f0 00 76 08 c4 06 2f 56  37 50 4d 30 76 08 c8 06   ..v.../V7PM0v...
  0340:  2f 52 37 44 30 39 89 1a  01 01 65 6e 67 43 6f 6e   /R7D09....engCon
  0350:  74 61 69 6e 73 20 61 64  75 6c 74 20 74 68 65 6d   tains adult them
  0360:  65 73 06 d0 e0 53 23 55  00 01 00 00 00 fe 50 06   es...S#U......P.
  0370:  f1 03 01 75 6e 64 50 06  f2 03 02 65 6e 67 50 06   ...undP....engP.
  0380:  f3 10 05 65 6e 67 4d a7  65 6e 67 0a 43 53 49 3a   ...engM.eng.CSI:
  0390:  20 4d 69 61 6d 69 98 52  75 73 68 3a 20 43 72 69    Miami.Rush: Cri
  03a0:  6d 65 20 64 72 61 6d 61  20 73 65 72 69 65 73 20   me drama series 
  03b0:  62 61 73 65 64 20 6f 6e  20 74 68 65 20 77 6f 72   based on the wor
  03c0:  6b 20 6f 66 20 66 6f 72  65 6e 73 69 63 20 69 6e   k of forensic in
  03d0:  76 65 73 74 69 67 61 74  6f 72 73 2e 20 54 68 65   vestigators. The
  03e0:  20 43 53 49 73 20 69 6e  76 65 73 74 69 67 61 74    CSIs investigat
  03f0:  65 20 77 68 65 6e 20 61  20 6d 6f 76 69 65 20 73   e when a movie s
  0400:  74 61 72 20 74 75 72 6e  73 20 75 70 20 64 65 61   tar turns up dea
  0410:  64 20 64 75 72 69 6e 67  20 66 69 6c 6d 69 6e 67   d during filming
  0420:  2e 20 28 53 35 20 45 70  20 32 30 29 5b 53 5d 5f   . (S5 Ep 20)[S]_
  0430:  04 00 00 23 3a 54 02 f0  00 76 08 c4 06 2f 56 33   ...#:T...v.../V3
  0440:  56 32 58 76 08 c8 06 2f  52 37 38 49 54 89 1d 01   V2Xv.../R78IT...
  0450:  00 65 6e 67 43 4f 4e 54  41 49 4e 53 20 46 4c 41   .engCONTAINS FLA
  0460:  53 48 49 4e 47 20 49 4d  41 47 45 53 71 85 c0 27   SHING IMAGESq..'

...

            DVB-DescriptorTag: 77 (0x4d)  [= short_event_descriptor]
            descriptor_length: 179 (0xb3)
              ISO639_2_language_code:  eng
            event_name_length: 33 (0x21)
            event_name: "Law & Order: Special Victims Unit"  -- Charset: Latin alphabet
            text_length: 141 (0x8d)
            text_char: "Crime drama series. Detective Cassidy is accused of raping a woman while he was working undercover as the trial of a pimp begins. (S14 Ep 17)"  -- Charset: Latin alphabet

And now from an event where the subtitle is included in the description so all works correctly:

------------------------------------------------------------
SECT-Packet: 00000551   PID: 18 (0x0012), Length: 382 (0x017e)
Time received: Wed 2016-02-03  15:42:40.720
------------------------------------------------------------
  0000:  51 f1 7b 32 e0 c9 00 f8  30 06 23 3a 00 51 08 69   Q.{2....0.#:.Q.i
  0010:  e0 51 00 25 00 00 50 00  01 07 50 06 f1 03 01 75   .Q.%..P...P....u
  0020:  6e 64 50 06 f2 03 02 65  6e 67 50 06 f3 10 05 65   ndP....engP....e
  0030:  6e 67 4d cf 65 6e 67 21  4c 61 77 20 26 20 4f 72   ngM.eng!Law & Or
  0040:  64 65 72 3a 20 53 70 65  63 69 61 6c 20 56 69 63   der: Special Vic
  0050:  74 69 6d 73 20 55 6e 69  74 a9 53 75 67 61 72 3a   tims Unit.Sugar:
  0060:  20 4e 65 77 2e 20 50 6f  6c 69 63 65 20 64 72 61    New. Police dra
  0070:  6d 61 20 73 65 72 69 65  73 20 61 62 6f 75 74 20   ma series about 
  0080:  61 6e 20 65 6c 69 74 65  20 73 65 78 20 63 72 69   an elite sex cri
  0090:  6d 65 20 75 6e 69 74 20  62 61 73 65 64 20 69 6e   me unit based in
  00a0:  20 4e 65 77 20 59 6f 72  6b 2e 20 42 65 6e 73 6f    New York. Benso
  00b0:  6e 20 61 6e 64 20 53 74  61 62 6c 65 72 20 69 6e   n and Stabler in
  00c0:  76 65 73 74 69 67 61 74  65 20 74 68 65 20 63 61   vestigate the ca
  00d0:  73 65 20 6f 66 20 61 20  77 6f 6d 61 6e 20 77 68   se of a woman wh
  00e0:  6f 73 65 20 62 6f 64 79  20 69 73 20 66 6f 75 6e   ose body is foun
  00f0:  64 20 69 6e 20 61 20 73  75 69 74 63 61 73 65 2e   d in a suitcase.
  0100:  5b 53 5d 5f 04 00 00 23  3a 54 02 f0 00 76 08 c4   [S]_...#:T...v..
  0110:  06 2f 56 36 36 39 4b 76  08 c8 06 2f 52 31 42 4b   ./V669Kv.../R1BK
  0120:  4d 08 6a e0 51 01 15 00  05 45 00 00 4d 50 06 f1   M.j.Q....E..MP..
  0130:  03 01 75 6e 64 50 06 f2  03 02 65 6e 67 4d 1e 65   ..undP....engM.e
  0140:  6e 67 0c 54 65 6c 65 73  68 6f 70 70 69 6e 67 0d   ng.Teleshopping.
  0150:  54 65 6c 65 73 68 6f 70  70 69 6e 67 20 54 02 30   Teleshopping T.0
  0160:  00 5f 04 00 00 23 3a 76  08 c4 06 2f 56 36 4f 35   ._...#:v.../V6O5
  0170:  30 76 07 c8 05 2f 52 41  58 4e 2b 53 0a fa         0v.../RAXN+S..

...

            DVB-DescriptorTag: 77 (0x4d)  [= short_event_descriptor]
            descriptor_length: 207 (0xcf)
              ISO639_2_language_code:  eng
            event_name_length: 33 (0x21)
            event_name: "Law & Order: Special Victims Unit"  -- Charset: Latin alphabet
            text_length: 169 (0xa9)
            text_char: "Sugar: New. Police drama series about an elite sex crime unit based in New York. Benson and Stabler investigate the case of a woman whose body is found in a suitcase.[S]"  -- Charset: Latin alphabet

comment:2 Changed 3 years ago by Daniel Foster <daniel@…>

At stuarta's request...

mysql> select chanid, serviceid, transportid, networkid, d.mplexid from channel as c, dtv_multiplex as d where c.mplexid=d.mplexid and chanid in (select chanid from program where title like 'Law & Order%' and subtitle='Special Victims Unit');
+--------+-----------+-------------+-----------+---------+
| chanid | serviceid | transportid | networkid | mplexid |
+--------+-----------+-------------+-----------+---------+
|   3021 |     12992 |       12294 |      9018 |     116 |
|   8710 |      7710 |        2057 |         2 |      38 |
|   8711 |      7711 |        2057 |         2 |      38 |
+--------+-----------+-------------+-----------+---------+

comment:3 Changed 3 years ago by Stuart Auchterlonie

Okay, similar result to my set

mysql> select chanid, serviceid, transportid, networkid, d.mplexid from channel as c, dtv_multiplex as d where c.mplexid=d.mplexid and chanid in (select chanid from program where title like 'Law & Order%' and subtitle='Special Victims Unit');
+--------+-----------+-------------+-----------+---------+
| chanid | serviceid | transportid | networkid | mplexid |
+--------+-----------+-------------+-----------+---------+
|   3021 |     12992 |       12294 |      9018 |       3 |
|   5083 |     41344 |       40960 |      9018 |      14 |
|   9711 |      7711 |        2057 |         2 |      48 |
|   9710 |      7710 |        2057 |         2 |      48 |
+--------+-----------+-------------+-----------+---------+
4 rows in set (0.00 sec)

comment:4 Changed 3 years ago by lomion@…

Your problem is in eitfixup.cpp line 855ff (fixes/0.27). Since your EIT does not contain any date or year and has ":" in the title it gets split but only if the description does not contain a ":". That's where your two examples differ.

I suggest adding

&& !event.title.startsWith("Law & Order:")

to eitfixup.cpp line 812

comment:5 Changed 3 years ago by lomion@…

Unit Test for it ...

void TestEITFixups::testUKLawAndOrder()
{
    EITFixUp fixup;

    DBEventEIT *event = SimpleDBEventEIT (EITFixUp::kFixUK,
                                         "Law & Order: Special Victims Unit",
                                         "",
                                         "Crime drama series. Detective Cassidy is accused of raping ...");

    PRINT_EVENT(*event);
    fixup.Fix(*event);
    PRINT_EVENT(*event);
    QCOMPARE(event->title,    QString("Law & Order: Special Victims Unit"));
    QCOMPARE(event->subtitle, QString(""));

    DBEventEIT *event2 = SimpleDBEventEIT (EITFixUp::kFixUK,
                                         "Law & Order: Special Victims Unit",
                                         "",
                                         "Sugar: New. Police drama series about an elite sex crime  ...");

    PRINT_EVENT(*event2);
    fixup.Fix(*event2);
    PRINT_EVENT(*event2);
    QCOMPARE(event2->title,    QString("Law & Order: Special Victims Unit"));
    QCOMPARE(event2->subtitle, QString("Sugar"));
}

comment:6 Changed 3 years ago by Karl Dietz <dekarl@…>

In 4651f99e8edb177359aadec6d6b74733276697ce/mythtv:

Add "Law & Order: UK" to the exceptions

Refs #12633

comment:7 Changed 3 years ago by Karl Dietz <dekarl@…>

Resolution: fixed
Status: newclosed

In 1a93f3dfc464bae9f6e07696c38d327839c245ef/mythtv:

special case for Law & Order in UK Fixups

based on a patch by lomion

Fixes #12633

(cherry picked from commit df43327e55367d8d50413a4ac8a3b3e66ef2a493)

Conflicts:

mythtv/libs/libmythtv/test/test_eitfixups/test_eitfixups.cpp
mythtv/libs/libmythtv/test/test_eitfixups/test_eitfixups.h

comment:8 Changed 3 years ago by Karl Dietz <dekarl@…>

In f4eddfa3000649ede1398c61d00cd4a4644a759b/mythtv:

Add "Law & Order: UK" to the exceptions

Refs #12633

(cherry picked from commit 4651f99e8edb177359aadec6d6b74733276697ce)

comment:9 Changed 3 years ago by Karl Egly

Milestone: unknown0.27.7
Note: See TracTickets for help on using tickets.