Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12649 closed Bug Report - General (fixed)

Program.pm from the perl bindings, Mythlink, and season specials

Reported by: mythtv@… Owned by: Karl Dietz <dekarl@…>
Priority: minor Milestone: 0.27.7
Component: Bindings - Perl Version: 0.27.5
Severity: low Keywords: Program.pm
Cc: Ticket locked: no

Description

I am using mythlink with MythTV 0.27.5 on Fedora 23 x86_64 using packages from rpmfusion.

With the recent updates to mythlink, it has the ability to create output including season and episode. This is most useful if you also consume mythtv content in xbmc, plex, etc. It is a great addition.

One gap that I have noticed though is the handling of special episodes.

I usually use this format: "%T/%T - S%ssE%ep - %S" to give output like:

The X- Files/The? X- Files - S10E01 - My Struggle.mpg

In the case of special episodes, those are usually season 0, but with an episode number. This yields:

American Ninja Warrior/American? Ninja Warrior - SE03 - USA vs. the World.mpg

The issue is in the format_name function in Program.pm from the perl bindings. If the season is 0, then it doesn't print anything.

The attached patch resolves the issue for specials. If the season is 0, but the episode > 0, it will set the season to '00'

Attachments (1)

Program.pm.patch (691 bytes) - added by mythtv@… 4 years ago.
Patch to resolve special seasons

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by mythtv@…

Attachment: Program.pm.patch added

Patch to resolve special seasons

comment:1 Changed 4 years ago by Karl Dietz <dekarl@…>

Owner: set to Karl Dietz <dekarl@…>
Resolution: fixed
Status: newclosed

In 4517c1284c273f779b6e378dcd2df219645a9f09/mythtv:

Add special case for specials / season 0 to Perl bindings

Based on patch by Michael <mythtv@…>
Refs #11919
Fixes #12649

comment:2 Changed 4 years ago by Karl Dietz <dekarl@…>

In 332aa34b1dda5dbfe7db548aa8c12818aa8f78de/mythtv:

Add special case for specials / season 0 to Perl bindings

Based on patch by Michael <mythtv@…>
Refs #11919
Fixes #12649

(cherry picked from commit 4517c1284c273f779b6e378dcd2df219645a9f09)

Note: See TracTickets for help on using tickets.