Opened 3 years ago

Closed 3 years ago

#12774 closed Bug Report - General (Invalid)

settings stuck with nonexistent DefaultChanid, can't watch live tv

Reported by: dbwood@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Unspecified
Severity: medium Keywords: settings DefaultChanid
Cc: Ticket locked: no

Description

In making mistakes scanning channel and upgrading to 0.28, I removed extraneous channels (found by scanning the hdhomerun instead of just using the SchedulesDirect? info). The settings table was left with DefaultChanid? = 3808, a no-longer-existent channel (or similar for the frontends), and none of my frontends could watch live tv any more. I changed it to a chanid for a known channel, using mysql, and all is now well again. I don't know how the bogus DefaultChanid? should have gotten resynced, I had tried removing and re-adding cards & etc, with default channel=3 to no avail.

Change History (1)

comment:1 Changed 3 years ago by Jim Stichnoth

Resolution: Invalid
Status: newclosed

For better or worse, this is "working as intended".

The problem is that a channel can go away, temporarily or permanently, for a variety of reasons, and there is no good way for MythTV to find a channel that is guaranteed to be tunable. This has been discussed a number of times in the past on the -users list.

The procedure in this case is: (1) Bring up the Program Guide (2) Navigate to a channel that you know in your heart to be tunable (3) Select MENU > Watch This Channel

Note: See TracTickets for help on using tickets.