Opened 3 years ago

Closed 2 years ago

#12825 closed Bug Report - General (Invalid)

Could not get card info for card /dev/dvb/adapter0/frontend0Subtype: Unkown error

Reported by: leafpaulc@… Owned by: Stuart Auchterlonie
Priority: minor Milestone: 0.28.2
Component: MythTV - DVB Version: 0.28.0
Severity: medium Keywords: mythtv backend, input card not found
Cc: Ticket locked: no

Description

I am using a turboSight TBS 6982se DVBS/S2 (satellite TV Card - dual tuner) in the UK

Summary:

The above card cannot be setup with mythtv 0.28 on mythbuntu 16.04 in the UK (although it works fine with 0.27.7 on exactly the same hardware with ubuntu 14.04), it is initially detected fine in mythtv backend setup but once the channel scan has completed the card returns the following error "Could not get card info for card /dev/dvb/adapter0/frontend0Subtype: Unknown error" on the Capture Cards screen. At this point the second tuner on the card is still detected correctly but you cannot get passed the DiSEqC (Switch, LNB, and Rotor Configuration) screen to set up LNB.

Note that I get the same issue on mythbuntu 14.04 with mythtv 0.28.

Steps to reproduce:

  1. New clean install using the current mythbuntu 16.04 iso (with Mythtv 0.28)
  2. Apply all updates using the standard repositories
  3. Reboot (to get the new kernel) and install the proprietory TBS drivers (tbs-linux-drivers_v160405.zip)
  4. Go into mythbackend set up and set up capture card
  5. Select DiSEqC (Switch, LNB, and Rotor Configuration)
  6. Click "Unconnected", and choose LNB (Universal LNB - with default settings)
  7. Set up video source
  8. Input connections - connect capture card to video source
  9. Input name: DVBInput also set Display Name and Video Source
  10. Click Scan for Channels - scan proceeds as normal - channels are detected and appear to be saved as expected.
  11. At this point everything has worked as expected.
  12. Exit mythbackend set up and go into the frontend - try to access tv - get the "please wait" overlay for a number of seconds and returned to mythfrondend screen
  13. Exit mythfrontend and launch the mythbackend setup
  14. Go to capture cards and select the already set up capture card
  15. The error "Could not get card info for card /dev/dvb/adapter0/frontend0Subtype: Unkown error" shows (see "screenshot1.png") - nb "screenshot2.png" shows the second tuner being correctly found - as the first one was initially.
  16. Go into "Input Connections" and now cannot scan for channels (as "Scan Type: failed to open the card")

I have a 0.27.7 installation on the same hardware which is working fine, this just seems to be an issue with 0.28 (possibly with my satellite card and/or using DVBS/S2).

The odd thing about the issue with 0.28 is that the card is, initially, found as expected and the setup proceeds normally, however, once setup has completed the card suddenly cannot be found. The second tuner on the card (at this point) is still detected correctly but on the DiSEqC (Switch, LNB, and Rotor Configuration) screen you cannot get passed the "Unconnected" line ie the LNB part cannot be accessed. For this particular clean install I haven't configured the second tuner so far.

The TV component of mythtv is unusable for me under 0.28 - I have set the priority/severity to minor/medium as I can't find other people with the exactly the same issue but it is critical/high for me.

Let me know if you need further information.

Attachments (5)

screenshot1.png (164.7 KB) - added by leafpaulc@… 3 years ago.
Screenshot of the error
screenshot2.png (165.0 KB) - added by leafpaulc@… 3 years ago.
Screenshot of the card being correctly detected
mythbackend.log (372.0 KB) - added by leafpaulc@… 3 years ago.
mythfrontend.log (47.2 KB) - added by leafpaulc@… 3 years ago.
mythtv-setup.log (66.1 KB) - added by leafpaulc@… 3 years ago.

Download all attachments as: .zip

Change History (19)

Changed 3 years ago by leafpaulc@…

Attachment: screenshot1.png added

Screenshot of the error

Changed 3 years ago by leafpaulc@…

Attachment: screenshot2.png added

Screenshot of the card being correctly detected

Changed 3 years ago by leafpaulc@…

Attachment: mythbackend.log added

Changed 3 years ago by leafpaulc@…

Attachment: mythfrontend.log added

Changed 3 years ago by leafpaulc@…

Attachment: mythtv-setup.log added

comment:1 Changed 3 years ago by Stuart Auchterlonie

Status: newinfoneeded_new

Setup is reporting that the devices are in use. Is something else using those devices at the time?

Jul  8 11:25:22 pvr mythtv-setup.real: mythtv-setup[4173]: E CoreContext cardutil.cpp:472 (ProbeDVBType) Can't open DVB frontend (/dev/dvb/adapter0/frontend0) for /dev/dvb/adapter0/frontend0.
Jul  8 11:25:22 pvr mythtv-setup.real: mythtv-setup[4173]: E CoreContext cardutil.cpp:1723 (ProbeV4LAudioInputs) ProbeAudioInputs() -> couldn't open device
Jul  8 11:25:22 pvr mythtv-setup.real: mythtv-setup[4173]: E CoreContext cardutil.cpp:1723 (ProbeV4LAudioInputs) ProbeAudioInputs() -> couldn't open device
Jul  8 11:25:22 pvr mythtv-setup.real: mythtv-setup[4173]: E CoreContext v4l2util.cpp:53 (Open) V4L2(): Could not open '/dev/dvb/adapter0/frontend0': #012#011#011#011eno: Device or resource busy (16)
Jul  8 11:25:22 pvr mythtv-setup.real: mythtv-setup[4173]: E CoreContext cardutil.cpp:472 (ProbeDVBType) Can't open DVB frontend (/dev/dvb/adapter0/frontend0) for /dev/dvb/adapter0/frontend0.
Jul  8 11:25:22 pvr mythtv-setup.real: mythtv-setup[4173]: E CoreContext cardutil.cpp:1723 (ProbeV4LAudioInputs) ProbeAudioInputs() -> couldn't open device
Jul  8 11:25:22 pvr mythtv-setup.real: mythtv-setup[4173]: E CoreContext v4l2util.cpp:53 (Open) V4L2(): Could not open '/dev/dvb/adapter0/frontend0': #012#011#011#011eno: Device or resource busy (16)
Jul  8 11:25:22 pvr mythtv-setup.real: mythtv-setup[4173]: E CoreContext v4l2util.cpp:53 (Open) V4L2(): Could not open '/dev/dvb/adapter0/frontend0': #012#011#011#011eno: Device or resource busy (16)
Last edited 3 years ago by Stuart Auchterlonie (previous) (diff)

comment:2 Changed 3 years ago by leafpaulc@…

No, mythbuntu is the only thing running. It is a single back end/front end system which nothing else can access. The install was also a brand new install to a clean partition

comment:3 Changed 3 years ago by Stuart Auchterlonie

Okay, can you run (as root)

# lsof /dev/dvb/adapter0/frontend0

comment:4 Changed 3 years ago by leafpaulc@…

COMMAND   PID   USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
mythbacke 830 mythtv   11u   CHR  212,3      0t0  554 /dev/dvb/adapter0/frontend0
Last edited 3 years ago by Stuart Auchterlonie (previous) (diff)

comment:5 Changed 3 years ago by Stuart Auchterlonie

Owner: set to Stuart Auchterlonie
Version: Unspecified0.28.0

Okay, so there is a backend running on this system and it's using DVB adapter0. When you run mythtv-setup you have to stop the backend first.

Can you please try running setup with the backend stopped, and the problem should go away

comment:6 Changed 3 years ago by leafpaulc@…

Sorry this is long winded but the behaviour is odd. I think that the mythbackend running is a red herring (partially at least or possibly a second issue), in that it gets rid of the card not recognised error in backend setup (once killed) but doesn't solve the underlying problem of the card not working with mythtv 0.28.

I don't think that the back end is running (initially - see output below), this is a clean install and on boot the mythbackend set up runs automatically. If I exit it prompts "Do I want to start the back end".

I still have the problem that the tuner doesn't work in the front end. From the output below it would appear that if the back end is running, then running mythbackend setup does not cause the backend to shutdown (which it should shouldn't it?).

See below for ps output.

This output is after the backend set up has started (still get the error with this but no backend running, just the backend set up):

sudo ps -ef | grep myth
paul      1454  1366  0 16:06 ?        00:00:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /usr/share/mythbuntu/session.sh
paul      1457     1  0 16:06 ?        00:00:00 /usr/bin/dbus-launch --exit-with-session /usr/share/mythbuntu/session.sh
paul      5449  1500  0 16:26 ?        00:00:00 /bin/sh /usr/bin/mythtv-setup
paul      5469  5449  0 16:26 ?        00:00:00 xterm -title MythTV Setup Terminal -e taskset -c 0 /usr/bin/mythtv-setup.real --syslog local7
paul      5470  5469 16 16:26 pts/0    00:00:01 /usr/bin/mythtv-setup.real --syslog local7
paul      5500  2179  0 16:26 pts/1    00:00:00 grep --color=auto myth

At this point I still get the card not recognised message.

When I exit back end set up and am prompted "Do I want to start the backend" - "Yes" I get:

sudo ps -ef | grep myth
paul      1454  1366  0 16:06 ?        00:00:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /usr/share/mythbuntu/session.sh
paul      1457     1  0 16:06 ?        00:00:00 /usr/bin/dbus-launch --exit-with-session /usr/share/mythbuntu/session.sh
mythtv    5628     1  3 16:30 ?        00:00:00 /usr/bin/mythbackend --quiet --syslog local7
paul      5650  2179  0 16:31 pts/1    00:00:00 grep --color=auto myth

Now if I try mythbackend set up again, mythbackend is running (as well as set up) - NB shouldn't I have received a prompt at the launch of mythbackend setup stating that mythbackend will be stopped? - I didn't get one:

sudo ps -ef | grep myth
paul      1454  1366  0 16:06 ?        00:00:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /usr/share/mythbuntu/session.sh
paul      1457     1  0 16:06 ?        00:00:00 /usr/bin/dbus-launch --exit-with-session /usr/share/mythbuntu/session.sh
mythtv    5628     1  0 16:30 ?        00:00:01 /usr/bin/mythbackend --quiet --syslog local7
paul      5755  1500  0 16:35 ?        00:00:00 /bin/sh /usr/bin/mythtv-setup
paul      5775  5755  0 16:35 ?        00:00:00 xterm -title MythTV Setup Terminal -e taskset -c 0 /usr/bin/mythtv-setup.real --syslog local7
paul      5776  5775 21 16:35 pts/0    00:00:01 /usr/bin/mythtv-setup.real --syslog local7
paul      5806  2179  0 16:35 pts/1    00:00:00 grep --color=auto myth

Followed by

sudo kill 5628
sudo ps -ef | grep myth
paul      1454  1366  0 16:06 ?        00:00:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /usr/share/mythbuntu/session.sh
paul      1457     1  0 16:06 ?        00:00:00 /usr/bin/dbus-launch --exit-with-session /usr/share/mythbuntu/session.sh
paul      5755  1500  0 16:35 ?        00:00:00 /bin/sh /usr/bin/mythtv-setup
paul      5775  5755  0 16:35 ?        00:00:00 xterm -title MythTV Setup Terminal -e taskset -c 0 /usr/bin/mythtv-setup.real --syslog local7
paul      5776  5775  2 16:35 pts/0    00:00:05 /usr/bin/mythtv-setup.real --syslog local7
paul      5906  2179  0 16:39 pts/1    00:00:00 grep --color=auto myth

Now the card is recognised (as you suggested) but when I try to add the second tuner on the same card (it is now also recognised), on the LNB* config screen it has "Unconnected" but doesn't open up the overlay to choose LNB and configure it when "Unconnected" is clicked. Nothing at all happens when "Unconnected" is clicked.

if I try to scan for channels on the second tuner I get "Failed to find any new channels!" possibly because the LNB part cannot be set up. Now that the first card is recognised I can scan for channels using it, they are listed but when exiting and running mythfrontend to view the tv I still get the 10 seconds of "Please Wait" then nothing (back to the front end tv etc menu).

Weirdly - on the fresh install ie just after the first installation I was able to set up the first tuner, including LNB and scanning channels apparently successfully but I cannot see live tv.

sudo ps -ef | grep myth
paul      1454  1366  0 16:06 ?        00:00:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /usr/share/mythbuntu/session.sh
paul      1457     1  0 16:06 ?        00:00:00 /usr/bin/dbus-launch --exit-with-session /usr/share/mythbuntu/session.sh
mythtv    6038     1  0 16:47 ?        00:00:00 /usr/bin/mythbackend --quiet --syslog local7
paul      6062  1500  0 16:47 ?        00:00:00 /bin/sh /usr/bin/mythfrontend --service
paul      6071  6062  4 16:47 ?        00:00:04 /usr/bin/mythfrontend.real --syslog local7
paul      6173  2179  0 16:49 pts/1    00:00:00 grep --color=auto myth
Last edited 3 years ago by Stuart Auchterlonie (previous) (diff)

comment:7 Changed 3 years ago by leafpaulc@…

Sorry about the formatting.....

comment:8 Changed 3 years ago by geoffc@…

On version 0.28 I am also getting this exact same situation with a TBS 6281 DVB-T2 dual-tuner card. It was working perfectly on 0.27 (at least for a while until it "lost" all the channels and needed a reboot - that's why I updated to 0.28). I'm running Linux Mint 17.2 Cinnamon with the open-source drivers for the TBS card.

I entered mythtv-setup and was invited to close the running myth backend, which I did of course. I determined that the Unknown Error was due to a "device busy" condition and suspected that the backend was nevertheless still running. I exited out of everything, closed the backend manually and reentered mythtv-setup. The card was recognized but a channel scan failed with timeout on all of them.

Exiting again, running w_scan from a terminal found all the channels ok.

comment:9 Changed 3 years ago by paulh

I'm going to close this as invalid. Like Stuart says you MUST stop the backend before you run mythtv-setup otherwise it can't probe the DVB cards.

You are correct that running mythtv-setup attempts to shutdown mythbackend but that requires things to be setup correctly so mythtv-setup runs the correct command and has the correct permissions to stop the backend.

comment:10 Changed 3 years ago by Stuart Auchterlonie

Milestone: 0.28.10.28.2

Moving remaining open 0.28.1 tickets to 0.28.2

comment:11 Changed 3 years ago by leafpaulc@…

This is not invalid, the backend is stopped prior to the probing by mythtv-setup, and still the card is not recognised.

I don't understand why you have concluded that the backend is still running when the error occurs, it definitely is not.

The card functions entirely normally in 0.27 but not 0.28. The card also worked fine in early nightly versions of 0.28 until some changes approx 12 months before the 0.28 release

If you read the above carefully (and I am aware that there is a lot of it), sometimes, initially the card is recognised, can be set up but once the backend is started the tv won't show and on then going back to the backend I am back to the error shown in Screenshot1.jpg attached earlier.

comment:12 Changed 3 years ago by Stuart Auchterlonie

I actually suspect that this is related to an issue i've seen where the backend doesn't shut down the first time it is told to shutdown.

In your case you use mythtv-setup to stop the backend, which it will try to do, but what it doesn't realize is that it's still running in the background.

To verify this, run your steps again, and when it can't access the card, drop to a shell and run ps -ef | grep mythbackend

comment:13 Changed 3 years ago by leafpaulc@…

Ok, happy for this to be closed now, the backend not shutting down was a red herring, that is still an issue but the tbs card now works (ie now shows TV) when it didn't previously

comment:14 Changed 2 years ago by Stuart Auchterlonie

Resolution: Invalid
Status: infoneeded_newclosed

Closing out, as this is caused by the backend still running

Note: See TracTickets for help on using tickets.