Opened 2 years ago

Closed 2 years ago

#13080 closed Bug Report - General (Invalid)

Fedora 24 -> 26: RPM build errors: Too many levels of recursion in macro expansion. It is likely caused by recursive macro declaration.

Reported by: udovdh@… Owned by: Stuart Auchterlonie
Priority: minor Milestone: 29.0
Component: Packaging Version: 0.27-fixes
Severity: high Keywords: macro recursion
Cc: Ticket locked: no

Description

Since I upgraded the MythTV box from fedora 24 to Fedora 26 I am unable to (re)build MythTV/MythWeb using the MythTV/packaging tools. I get errors like in the summary. I opened a bug in the Redhat bugzilla for this problem but they refer to MythTV: https://bugzilla.redhat.com/show_bug.cgi?id=1475439

How can I build MythTV rpms again? What is the root cause of this issue? How can I find out?

Change History (7)

comment:1 Changed 2 years ago by Stuart Auchterlonie

Milestone: needs_triage29.0
Owner: set to Stuart Auchterlonie
Status: newaccepted

I'll take a look at this, those spec files haven't been updated for ages tho.

comment:2 Changed 2 years ago by Stuart Auchterlonie

Status: acceptedinfoneeded

Actually, please just use the packages from rpmfusion https://rpmfusion.org/

Does this work for you?

Regards Stuart

comment:3 Changed 2 years ago by udovdh@…

What input can I give to help find a root cause? logs, configs, etc?

comment:4 in reply to:  2 Changed 2 years ago by udovdh@…

Replying to stuarta:

Actually, please just use the packages from rpmfusion https://rpmfusion.org/

Does this work for you?

I can look at their packages over this weekend.

comment:5 Changed 2 years ago by udovdh@…

Issue was caused by ~/.rpmrc that contained:

optflags: x86_64 -march=k8 -mtune=k8 -msse -msse2 -msse3 -m3dnow %{__global_cflags} -m64

yet in F26 /usr/lib/rpm/redhat/macros contains a line saying:

%__global_cflags	%{optflags}

(this was not the case before)

comment:6 Changed 2 years ago by udovdh@…

In F24 /usr/lib/rpm/redhat/macros contains a line saying:

%__global_cflags        -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches %{_hardened_cflags}

So I think we can close this ticket.

comment:7 Changed 2 years ago by Bill Meek

Resolution: Invalid
Status: infoneededclosed

Thanks for reporting back.

Note: See TracTickets for help on using tickets.