Opened 2 years ago

Closed 2 years ago

Last modified 16 months ago

#13083 closed Bug Report - General (Invalid)

Cannot switch to channel in guide that is on a different source

Reported by: clueo8@… Owned by: Peter Bennett
Priority: minor Milestone: 29.0
Component: MythTV - General Version: 0.28.1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have two sources, cable and OTA (HDhomerunPrime and HDhomerunATSC). If I'm currently watching something on the cable source and then go to the guide during playback and try to change channels to something on the OTA source, it simply doesn't change the channel, it just closes the guide and continues back to watching the channel I was previously on. A workaround is the not use the guide, but to manually key in the channel number, or change the source in the menu to my other source and then the guide will allow me to select channels, but only under the source I'm currently on.

Change History (5)

comment:1 Changed 2 years ago by Peter Bennett

Owner: set to Peter Bennett
Status: newassigned

comment:2 Changed 2 years ago by Peter Bennett

Status: assignedinfoneeded

I tried this and it works fine with VDPAU Slim (Ceton cable tuner and PCTV OTA tuner). With OpenGL Slim, it changes channel successfully but only audio is heard from the changed channel, which seems like a different problem from yours.

Please let me know what playback profile you are using.

Also does your problem occur if you first tune the OTA channel then switch to the cable channel via the guide?

Last edited 2 years ago by Peter Bennett (previous) (diff)

comment:3 Changed 2 years ago by Peter Bennett

Resolution: Invalid
Status: infoneededclosed

Please disregard the prior comment. On V0.28.1 I see the exact same issue you report. On V29 and master the problem is solved. Solution - upgrade to v29.

comment:4 Changed 2 years ago by Stuart Auchterlonie

Milestone: needs_triage29.0

comment:5 Changed 16 months ago by Peter Bennett

Owner: changed from Peter Bennett to Peter Bennett
Note: See TracTickets for help on using tickets.